Jump to content
GMS, SMS, and WMS User Forum

Shape Files


Derek
 Share

Recommended Posts

:angry:

I am using a shape file to bring in river data. It worked fine. Then I edited it in ArcView. When I try to bring it back into GMS, I get the message:

"Error reading from binary file (unknown shape record -1604762452)"

I have copied the dataset in ArcCatalog and the same thing happens when I tried to open the new file.

The file is not open in any other program.

Any ideas?

I ahve attached the shape file.

river_shape.zip

Link to comment
Share on other sites

I am not sure what has changed in the shape file that makes it so that GMS won't read it. However, it sounds like you have access to Arc View and if so you can use Arc to read the shape file from with in GMS. In the GIS module select the 'Enable Arc Objects' command from the GIS menu. Then use the 'Add Data' command from the GIS menu to add the shape file.

I went through those step and exported your river back out to shape. I have attached the file which GMS can read.

I removed the file that I saved from GMS and I replaced it with a shp file that I exported from Arc Catalog. I just right clicked on the shape file and did the export command and saved out a new shape file. The new file reads into GMS just fine.

tal_river3.zip

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...