Jump to content
GMS, SMS, and WMS User Forum

FEMWATER crashing on simple problem


woodward
 Share

Recommended Posts

Hi, I am having problems with FEMWATER crashing, has anyone seen this before?

I have set up a simple saturated transient flow+transport model in GMS on a rectangular mesh. Flow is constant in the x direction. Contaminant enters at the upstream boundary (x=0).

GMS sets up the relevant FEMWATER input files, I then need to correct the *.3bc file by putting in the correct number of print times in the OC1 card and the effective porosity ratio in the MP5 card.

When I run FEMWATER it hangs in the first iteration (whether I run it from GMS or through the command line or from my Fortran compiler). It also happens from two other versions of FEMWATER I have.

I am guessing that FEMWATER.exe is compiled with floating point exception level set to 3, and that is why it hangs instead of crashing. My compiler documentation says: "For performance reasons: On x86 systems, the default is /fpe:3. Using /fpe:0 will slow run-time performance on x86 systems."

Running FEMWATER from the compiler in debug mode I found a divide by zero error occurring in the Lagrangian particle backtracking code (SUBROUTINE BRKINS variable SUM2 = 0). Does anybody have any idea why this would happen? As far as I can see I have set up the problem correctly, and a similar problem runs ok. I have tried fiddling with the types of boundary conditions and the mesh spacing but this has not helped.

I would really appreciate any help with this.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...