Jump to content
GMS, SMS, and WMS User Forum

Memory Not Enough in SEAWAT


Recommended Posts


I have created MODFLOW model for a region near the coastline and It ran successfully in both steady and transient state. Currently there is no sink or source terms to make the model simple. Once the model achieve a stable solution, they will be added later. Then, I tried to run it in with SEAWAT and model shows the error that Memory is not enough.


I tried both Parallel, 64Bit options as well as  both of them in combination but did not get any luck. The way that I ran the SEAWAT model is as follows. I assume that I did it correct but please let me know if you have any alternative ways.

1.       Run MODFLOW in steady state.

2.       Change the model and output to transient state.

3.       Assign steady state heads in step 1 above as the initial heads for the run.

4.       Map MODFLOW to the grid.

5.       Map MT3DMS to the grid.

6.       Run SEAWAT.

My model grid has 512 x 646 x 12 cells (12 layers). Number of total and active cells are 3,969,024 and 1,416,464 respectively .

Since I did not have any success in running the model in GMS, I decided to run the SEAWAT model in text based USGS format. I exported the MODFLOW model from GMS to the regular text based USGS format. However, I do not see such a format change for either MT3DMS and SEAWAT option in GMS. 

1.       I assume that either MT3DMS or SEAWAT does not require such a conversion. Please correct me if I am incorrect.

2.       Also, I think that the SEAWAT name file in the SEAWAT folder that GMS produces (.swn file) may not be the correct one to run SEAWAT in USGS format because the type, format, number of files and the content in the files are different. Please see the files and sizes of GMS and USGS formats of MODFLOW in the screen shots below. Can you please advise me how to make the name file to run in USGS format using these GMS files?



I am planning to use the USGS version of SEAWAT executable and/source code to run the model since Aquaveo executable might have been customized to its data file types and may not match the requirements. Please let me know if you have any suggestion on this.

I very much appreciate all your thoughts, suggestions and help to resolve this issue.

Best regards,


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...