Jump to content
GMS, SMS, and WMS User Forum

Angle relaxation method


Fernando
 Share

Recommended Posts

When I use angle relaxation method in a mesh it seems to me that it doesn’t work right. In the SMS wiki the explanation of Angle relax is that it equalizes the angle of elements adjacent to each node, but when I use it there are some areas of the mesh where the elements connected with the same node becomes very different from each other, some elements with angles of about 110 – 120 degrees and others with angles less than 30 degrees. The more I relax the mesh, the worst it stays. I was expecting to achieve results similar to a procedure call springs used in xmgredit (a mesh editor and generator) but I can’t. I don’t know if I’m doing something wrong or if there are some options that I must change.

Any help would be appreciated.

Fernando

Link to comment
Share on other sites

Please contact technical support at support@aquaveo.com. They will give you instructions on where you can upload your files so we can take a look at it and see if there is a bug that needs fixing.

When I use angle relaxation method in a mesh it seems to me that it doesn’t work right. In the SMS wiki the explanation of Angle relax is that it equalizes the angle of elements adjacent to each node, but when I use it there are some areas of the mesh where the elements connected with the same node becomes very different from each other, some elements with angles of about 110 – 120 degrees and others with angles less than 30 degrees. The more I relax the mesh, the worst it stays. I was expecting to achieve results similar to a procedure call springs used in xmgredit (a mesh editor and generator) but I can’t. I don’t know if I’m doing something wrong or if there are some options that I must change.

Any help would be appreciated.

Fernando

Link to comment
Share on other sites

  • 4 weeks later...

Fernando,

I was able to look into the issue you reported. I found an issue with the "Allow sliding on mesh boundary" option, which will be fixed in our next update of SMS. Once this update is available, use the "Allow sliding on mesh boundary" option in the Element Options dialog? Try using this option and various "Sliding angles" . When I turned on this option, the results were much better.

The number of relaxation iterations should usually be kept low. Significant modifications of mesh nodal locations / density / connectivity should be handled using the mesh generation options rather than relaxation.

I also discovered that elements 41429 and 41419 in the mesh you sent to tech support are overlapping elements (nodes 2119, 11099, 11024) through the Mesh | Check Mesh command.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...