Jump to content
GMS, SMS, and WMS User Forum

Fixed pilot points in PEST NSMC


Recommended Posts

I have problems running PEST NSMC with fixed pilot points. Both in my own model and in the NSMC tutorial files, I get the same error message "Cannot open parameter value file nsmcII_200_random_nul.par." and the simulation finishes without completing any iteration. Is this a bug i in GMS?

Kind regards,


Error fixed pilot point.JPG

Link to comment
Share on other sites

An update on this matter. As suggested by Michal, I was able to run the PARREP and RANDPAR utility in PEST to create the *.par files for the different runs. Before running PARREP, I ran a parameter estimation run in GMS with NOPTMAX = -1 to create a *.bpa file. After running RANDPAR I was able to perform the normal procedure for a NSMC inverse calibration run in GMS. This worked out well for the NSMC tutorial with "sc1v56" as a fixed pilot points (keeping value 400 in screenshot below). I cross my fingers that it also works for my own model. However, I would appreciate if this procedure could work directly in GMS. 


Link to comment
Share on other sites

An update, my own model was possible to run after using the SUBREG1 utility in PEST. A problem is that my own model with a fixed pilot point is only possible to run for log-uniform distributions with the RANDPAR utility. When I try to create log-normal distributions in RANDPAR i get the error message seen in the screenshot below. Ideas on how to solve this issue are appreciated.  


Link to comment
Share on other sites

  • 4 weeks later...
  • 1 month later...

I just tested the model again without parallel PEST and got the same error message: "pest has stopped working". I get this when I make a parameter estimation run with noptmax = -2.

I also got this error message when from this run:


The whole process before seems to work fine


Edited by Jonas
Link to comment
Share on other sites

  • 3 weeks later...

Hi, I have encountered the same error with my model. The reason why PEST and PESTCHEK crashed has something to do with the Regularization option. With Prefered homogeneous regularization option checked several empty regularization observation groups were created in the PEST control file. I believe there is something wrong with the Prior information data section in the PEST control file. After turning Regularization off or changing to it Prefered value everything runs just fine. There are three scatter point sets in my model with many parameters for different model layers. There are Totaly 18 parameters defined with PP for multiple model layers. It looks to me like some bug in writing the Prior information with such setup.

Edit1: There were no fixed PP in my formulation.

Edit2: There seems to be more errors.  Here are some of the parameters and corresponding PI written by GMS:

 sc1v1        log    factor      22.321      1.00000E-08   1000.0          general   1.0000       0.0000       1
 sc1v2        log    factor      16.947      1.00000E-08   1000.0          general   1.0000       0.0000       1
 sc1v3        log    factor      4.1647      1.00000E-08   1000.0          general   1.0000       0.0000       1
 sc1v4        log    factor      4.4251      1.00000E-08   1000.0          general   1.0000       0.0000       1
 sc1v5        log    factor      33.072      1.00000E-08   1000.0          general   1.0000       0.0000       1

* prior information
 pi0 1.0 * log(sc1v1) = 3.1055498123169 1.0 regul_1
 pi1 1.0 * log(sc1v2) = 2.830082654953 1.0 regul_1
 pi2 1.0 * log(sc1v3) = 1.4266545772552 1.0 regul_1
 pi3 1.0 * log(sc1v4) = 1.4872899055481 1.0 regul_1
 pi4 1.0 * log(sc1v5) = 3.4986937046051 1.0 regul_1

Log10(22.321) = 1.349, not 3.106 as supplied by GMS. Its the natural logarithm. However according to the PEST manual, it must be decadic:


If a parameter is log-transformed, any prior information pertaining to that parameter must pertain to the log (to base 10) of that parameter.

PEST manual p.41


Edited by Michal
Link to comment
Share on other sites

Ok, thats definately a progress, PEST does not crash anymore :). This is realy a weird bug, it should not crash so violently.

To your new problem. Try turning SVD-Assist and Regularization off and set NOPTMAX to 0. Lets see if it works. Also try running PESTCHEK and examine the output.

Link to comment
Share on other sites

Hi, stupid question but how do I change from estimation mode to regularization mode in GMS? I have tried to use the PARREP utility to make a change in the pst (PEST control file) file but GMS keeps to run in estimation mode.

6 hours ago, Michal said:

To your new problem. Try turning SVD-Assist and Regularization off and set NOPTMAX to 0.

I tried this and then the model was able to run once (really fast). I have however not examined the results with PESTCHEK.

As I mentioned earlier, I have been able to make this work without fixed pilot points.

Link to comment
Share on other sites

Hi, no problem, you are welcome.

In GMS it should be automatic, based on whether you check either Prefered homogeneous regularization or Prefered value regularization. However according to the recent experiences I strongly recommend not to do it this way. Be aware of the bug mentioned earlier regarding the usage of natural logarithm instead of decadic in GMS. I have no idea how this impacts the inversion process, but I would avoid it. If you have no log-transformed parameters, it should not be a problem, though.

You can add prefered value regularization to the control file very easily by using the command line utlity from the PEST suite called ADDREG1. See the documentation to PEST (newpestman2.pdf, p. 21). It should make all the changes to the Control file necessary to run regularized inversion.

Edited by Michal
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...