Jump to content
GMS, SMS, and WMS User Forum

SRH2D Pre Error


Recommended Posts

I went back to a model that I hadn't worked on in 9 months or so.  Everything seems to be set-up ok (bc reasonable, mesh, etc), but I keep getting the run error message that the srh_pre-v30.....exe file is unknown (see attached screen shot).  Which I thought might mean the program can't find the executable. But when I go to preferences, it is pointing to the right folder and executable. 

Is running from a previous version a problem?  Thoughts?




Link to comment
Share on other sites

Hello.  The SRH-2D simulation should be able to run from a previous project. 

The "sof.dat" file created by SRH-Pre will contain all the input that was processed by SRH-Pre.  Looking at it or stepping through the SRH-Pre run in partial mode can give greater insight about what is not working.

Another option would be to make sure you have exported the SRH input files again.  That would replace all the input you have so you may want to save them for forensic reasons.

Finally, if you submit your data files to the Aquaveo tech support group, we can evaluate the project to see what is wrong.

Link to comment
Share on other sites

  • 2 weeks later...

I reviewed the sof.dat file, and it just ends after running through the manning's n file, right when it should be reading the boundary condition info.  I  have tried relinking, recreating, etc the boundary conditions (multiple times), but I keep getting this error message.  It is like it can't "find" the boundary conditions.  Should you need to recreate the BC coverage every time? 

Link to comment
Share on other sites

Where did your SOF file come from?  Was it created when you launched SRH from inside of SMS?

Which version of SMS are you using?  SMS 11 used what SRH referred to as the "Full" interface.  SMS 12 uses what SRH refers to as the "Custom" interface.

If SMS 12.1 or SMS 12.2 are creating an incomplete SOF file, I would be very interested in getting the data files and resolving this issue as a bug.


Link to comment
Share on other sites

I'm running 12.1.2.  The sof file was created when I launched SRH from inside of SMS.  What is even more strange, is that I ran this model on Friday, and it worked.  I made some changes to my mesh, regenerated the mesh, and then tried to run it again - with the same BC coverage.  Maybe this particular model is getting hung-up somehow?  Attached is the sof file from the recent run(s), and the one from this weekend that ran successfully.  I did send an email to support with this info as well.  Thanks!


100_SOF - Copy.dat

Link to comment
Share on other sites

  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...