Jump to content
GMS, SMS, and WMS User Forum

Section lines Formatting to enable XS2D Wizard


Recommended Posts

I have a question about section lines and activating the XS2D Wizard. I’ve created my section lines following the Aquaveo tutorial, but when I try and activate the XS2D wizard, I get the message:

 “Please add a Section Line layer that follows the Arc Hydro Groundwater Schema to the map before using this tool”

My attribute table is below.

Note: The only step I could not preform was the “Assign HydroID” because I was notified that “UNIQUEID” (PG. 12 OF XS2D tutorial) file “does not exist.” Therefore I manually assigned my own.

Please let me know if there are any suggestions to move forward.



Link to comment
Share on other sites

The wizard wants a visible polyline feature class loaded in the active map, with some of the default Arc Hydro Groundwater field names & types, and a projected coordinate system.


Make sure that you're not in an XS2D data frame when you try to use this tool, and that the SectionLine layer is turned on (visible) in the table of contents.  Also, check if your coordinate system is geographic or projected.  Finally, from your screenshot, I can't tell what the actual field names are because it looks like the Alias names are being shown instead ("Vertical Exaggeration" is an alias).


The wizard is looking for the following fields, please double check them by right clicking on your SectionLine layer in the Table of Contents, and choosing Properties, and looking on the Fields tab:

HydroID (integer)

SName (string)

VertExag2D (double)





Link to comment
Share on other sites

Thanks Doug!

I found that the Section lines layer did not have a projection system defined. So I defined it, got a new error message, then realized I needed to create a "XS2D catalog table" first with the correct headings, and that did the trick!

Thanks so much for your help.

Link to comment
Share on other sites

I was able to progress to running the XS2D Wizard. It seemed to run without error, but appears unsuccessful, as a second data frame (the XS2D data frame) is not added to my map (when I am in layout view). Some new features show up in my table of contents ("XS2D_Boreline_23" and "XS2D_Panel_23"), but when I zoom to them, they show up as points and not located near the well data. I also noticed XS2D_Panel_23 does not have a projection defined.

Below is my Table of contents and Layout Data frame results after running the XS2D wizard.

Any suggestions on what I might be doing wrong?




Link to comment
Share on other sites

Here is a bit of additional info:

I followed all the defaults for the XS2D Wizard, but it only created Boreline and Panel types for XS2D types, and no panel divider, major grid or minor grid files were created. (See XS2D catalog table below).

Any help would be greatly appreciated!

XS2D catalog.PNG

Link to comment
Share on other sites

Check the "Default output workspace" on Step 1 of the wizard.  This should be by default the same workspace as the SectionLine4.  I would suggest moving your SectionLine and Well features into a new feature dataset, with a projected coordinate system.  This way, you'll ensure that the output XS2D feature classes have the same projected coordinate system.

After creating the XS2D Boreline feature class, the wizard will try and read the Well and Borehole Log data, if that option is turned on.  It's the "Yes" or "No" radio button on Step 1.  If it's turned on, it will try and create the XS2D Boreline features.  Were any features created in XS2D_Boreline_23?

Because these XS2D features are two dimensional features representing 3D data, they won't show up next to your well data.  They should be displayed in their own data frame inside ArcMap, so that the X dimension in ArcMap is really the distance along the SectionLine feature, and the Y dimension in ArcMap is the vertical profile scaled by the vertical exaggeration.  So, on the XS2D panel, X=0 where the SectionLine starts.  It doesn't make sense to view them in ArcScene.  ArcMap is used for viewing in plan view, but the XS2D data is just a way to view a cross section profile.  The data has just been transformed so you can view it in ArcMap.  When finished, you can convert the XS2D data to true 3D objects (see the GeoSection tutorial) if you wish.

After the XS2D Boreline features are created (if you've turned this option on), it tries to create the XS2D panel dividers, and then it tries to create all the grid lines based on Step 3 of the wizard.

I'd try making a new feature dataset with a projected coordinate system, and placing your SectionLine and Well features inside of that, and then try running the wizard again.  When you run the wizard, just leave the default options for the output workspace, keeping it so that it's the same feature dataset as your SectionLine and Well.  You could also check the "Results" window to see if there were any problems running some of the geoprocessing tools.  What was the last tool run, and were there any errors reported?

Link to comment
Share on other sites

Hi Doug,

Thanks again for your advice.I really appreciate it!

I tried putting my wells and section line files into a new feature dataset, however XS2D wizard didn't like that (read 0 wells detected), so instead I just exported my sectionline file to be housed under the "Framework" default feature class, alongside the "well" file.

I tried the wizard again and it seemed to work (no error messages, see results image below).

Features were also successfully created in XS2D_Boreline_23_2 (see attribute table below).

However I still can't figure out where to view the resultant data in ArcMap. I tried resizing my first data frame in layout view, to see if there was a 2nd frame hiding behind, but it is there (see 3rd image below).

Am I missing it somewhere or did the wizard not perform correctly? I am trying to move onto the next steps (pg. 18 of tutorial), but it looks like I have a roadblock.

Thanks again,



Boreline Attribute table.png


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...