Jump to content
GMS, SMS, and WMS User Forum

Problem running seawat


Recommended Posts

I have a working modfow and MT3DMS model of my study area. However, when I try to run seawat the model fails, and I get a "Premature end of file...". It seems that seawat runs, but does not calculate anything. I've attached a figure with prompt window for the seawat solution.

Any help would be much appreciated.


Link to comment
Share on other sites

From the screenshot of the SEAWAT dialog it appears SEAWAT finished successfully. Does the "Premature end of file..." message appear after closing the SEAWAT dialog? Does it say anything else in the message?

You could find out more info about how SEAWAT ran by opening and inspecting the model3_sw.out file in a text editor. The model3_sw.out file would be in the model3_sw_MODFLOW folder. You could view it by opening NotePad and then dragging the file onto NotePad.

Link to comment
Share on other sites

It's actually 4 messages that appear when I close the window: (1) "Error reading  M:\pc...model3_sw.hed. File formatted incorrectly" (2) "Premature end of file model3_sw.ccf" (3) Premature end of file model3_sw.ccf2" and (4) "The following data sets were invalid and have been removed from the Project: Salt".

I tried comparing the model3_sw.out file with a corresponding file from a SEAWAT-simulation that works (a different model). I can't see any different between the two files (besides the model input values) before the model3_sw.out-file ends with a "CANNOT SPECIFY MORE THAN NSS STREAM SEGMENTS", which is the last sentence in the file. I've tried figuring out what it means, but  with no luck. 

EDIT: I'm using the SFR2 stream packaged in my model if this has anything to say.

Edited by jonasthu
Link to comment
Share on other sites

Hi Jonas,

Those four error messages after closing the SEAWAT model wrapper  occur because the "Read solution on exit' option is checked and the solutions GMS tried to read in were invalid because there were issues in the SEAWAT run. AS for the .OUT file message that says " CANNOT SPECIFY MORE THAN NSS [Number of Stream Segments] STREAM SEGMENTS" meaning it cannot identify more than 20 stream segments or whatever NSS number was given.

"NSS An integer value equal to the number of stream segments (consisting of one or more reaches) that are used to define the complete stream network. The value of NSS represents the number of segments that must be defined through a combination of parameters and variables".

There must be some stream segment somewhere that's not meeting specifications for use in SEAWAT so SEAWAT says there's too many stream segments, perhaps? I would check your stream arcs again to make sure there's not any irregularities like a little segment somewhere. It sounds like MODFLOW is outputting a file that SEAWAT can't process and it has to do with the NSS value.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...