Jump to content
GMS, SMS, and WMS User Forum

Export Native Text Files


Bruce Campbell
 Share

Recommended Posts

Hi -- I've got something that looks like a bug when I run the "Export Native Text" command. The problem is in the file that's output for the STR package. The STR inputs for Discharge, Conductance and the Top and Bottom altitudes for the individual stream reaches are pushed together without spaces. Here's an example from the beginning of the file:

     70883     14353         3         0         0  128390.4       740         0
     70883         0         0
    8    8   76    1    1            0.0313.580463 7448.3589313.579456313.580463
    8    7   76    1    2            0.0344.32457613513.4918344.323569344.324576
    8    7   75    1    3            0.0316.22881841210.9933 316.22781316.228818
    8    7   74    1    4            0.0292.13801741757.7071 292.13701292.138017
    8    7   73    1    5            0.0272.52672941382.5175272.525722272.526729

This gives an error when I attempt to run the model outside of GMS.

Link to comment
Share on other sites

Trying the option to save a native text copy (select MODFLOW | Global Options... menu then toggle on Save native text copy) should work. Then when you save the project it should give you a text export in a new folder along side the GMS MODFLOW folder.

This could be caused by changes in the STR file format with the 1.11.00 release of MODFLOW-2005. With  MODFLOW-2005 v1.11.00 the format used for the STR package changed from always fixed format (where numbers running together could be read by MODFLOW) to either fixed or free format depending on the Basic package setting. GMS saves MODFLOW files using free format. The native text export should work with either fixed or free format so it could also be read by older versions of MODFLOW-2005.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...