Jump to content
GMS, SMS, and WMS User Forum

write access error to TEMP directory


Recommended Posts

I'm currently running a CMS-Flow/CMS-Wave steering simulation on SMS 10.1

After it runs for about 12 hours I got this message:

"No write permission in specified directory c:\users\mike\appdata\local\temp for temp files"

SMS then asks for a directory that I have write access to, nothing I enters works (same message)

weird thing is CMS has been writing to that directory all night (this sim will need to run about 4 days)

I use Windows 7 and yes I have admin privileges.

Has anyone run into this problem before? Is there a TEMP limit size I have bumped into?

Not sure if this problem is with Win7, SMS, or one of the CMS programs.

Thank You

Link to comment
Share on other sites

It has been well over a year since I worked with SMS 10.1, but this did happen a time or two. One possible cause is that the drive is full. Have you checked that? If you are saving the intermediate files that is a possiblity. The process was streamlined and made more efficient with SMS 11.0. The CMS developers are planning on only having the inline steering (with CMS-Wave embedded in CMS-Flow) for the version of CMS that will be distributed with SMS 11.0.

Link to comment
Share on other sites

Thanks Alan, the drive has plenty of space. SMS 11 has problems Steering CMS-Wave/Flow so we reverted back to SMS 10.1. The inline model has many issues before we can use it, I believe that is still in the development stage.

SMS is creating many files in the %TEMP% folder (the ones with random number file names) and it looks like a threshold has been reached? I've cleaned out my TEMP folder and restarted, we'll see if it runs longer, if it does that will be the culprit. I've got a few other ideas I can try.

Link to comment
Share on other sites

There was a problem with SMS 11 CMS steering, but that was resolved in the past couple months. I worked with Lihwa Lin to test it. The inline version is not ready until they release it for use with SMS 11.1.

You may want to try the latest post of SMS 11 (11.0.11) from last week. I can check with folks at ERDC doing really long term runs if that doesn't work.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...