Jump to content
GMS, SMS, and WMS User Forum

FEMWATER - model checker


GMS User
 Share

Recommended Posts

I've build a femwater model with the conceptual model approach.

When I check the model I got the followings errors and warnings.

Errors and warnings generated by the GMS Model Checker:

RUN OPTIONS:

No warnings detected.

No errors detected.

MESH QUALITY:

No warnings detected.

Error: Element 5 is a five nodes element.

Error: Element 9 is a five nodes element.

Error: Element 11708 is a five nodes element.

INITIAL CONDITIONS:

No warnings detected.

No errors detected.

TIME CONTROL:

No warnings detected.

No errors detected.

OUTPUT CONTROL:

No warnings detected.

No errors detected.

MATERIALS:

Warning: Kxx values between elements 2 and 30146 differ by more than 3 orders of magnitude.

Warning: Kxx values between elements 4 and 30144 differ by more than 3 orders of magnitude.

How can I fix the five node element error?

I create a 2d mesh and triangulate it.

The 3d mesh has been built from boreholes and cross-section (horizons -> 3d mesh with min element thickness and target layer thickness - default values).

Thanks

dlattuada

Link to comment
Share on other sites

Did the model run? or did you get a Femwater error?

Do you have pinchouts in your model (layer thickness -> zero)?

Did you try Mesh|Find Duplicate Nodes?

Another thing you can try is Mesh|Renumber (you have to select a boundary face before you do it).

Simon

Edited by woodward
Link to comment
Share on other sites

Did the model run? or did you get a Femwater error?

I check the model with the model checker (as I do with modflow) before running it.

T try to run but no read solution.

Do you have pinchouts in your model (layer thickness -> zero)?

From Boreholes, Horizons -> 3d mesh I use boreholes data (elevation/botton), inverse distance interpolator, min thickness 0.09 m and the default values for target layer thickness.

Did you try Mesh|Find Duplicate Nodes?

I get this msg: 'remove all elements before finding duplicate nodes'

Which are the element to remove?

Another thing you can try is Mesh|Renumber (you have to select a boundary face before you do it).

I select and renumber. Same errors.

Thanks

dlattuada

p.s.

I edit my profile and my reputation is 'poor'. Why?

I posted help questions and replay to 1 user.

Link to comment
Share on other sites

Hi D

Are you saying it did not run? Was there a FEMWATER error?

Do you have pinchouts in your mesh layers?

I don't know about the profile reputation. I wouldn't worry about it.

Link to comment
Share on other sites

On the last page of the Horizons->3D Mesh page there is an option to Refine elements. The Refine all elements option will generate a mesh with all tetrahedra elements (4 node elements). The Refine layers with pyramid elements will convert all of the elements in a layer (or horizon) to 4 node elements. Either option should remove all 5 node elements from your mesh.

Link to comment
Share on other sites

On the last page of the Horizons->3D Mesh page there is an option to Refine elements. The Refine all elements option will generate a mesh with all tetrahedra elements (4 node elements). The Refine layers with pyramid elements will convert all of the elements in a layer (or horizon) to 4 node elements. Either option should remove all 5 node elements from your mesh.

Great! this solves the model checker error message.

I made a simplified version of the femwater model and compared it to a modflow one.

- brief

one layer

two bc - constant head (h=2 and h=0 sea level)

top and bottom elevation derived from boreholes data (scatter data)

refined elemnts

I attached the following screen capture show computed head contouring:

4-1 = modflow with 1 layer grid (top and bottom elevation interpolated), plus obs wells, everything seems ok

4-2 = modflow with grid (mean values for top and bottom elevation), plus obs wells, everything seems ok

4-3 = femwater with 1 layer grid (top and bottom elevation interpolated), plus obs wells.

The 4-3 model show the total head that is the same as head in modflow. Is it correct?

Why the contouring 4-3 is so different? I run the model with different starting heads and the computed heads depends from the initial condition.

I coudn't get the obs wells (in conceptual model - obs point) to have the computed head value. I tried to fix their z elevation to match the 3d grid elevation but without success.

Thanks

dlattuada

Edited by GMS User
  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...