Jump to content
GMS, SMS, and WMS User Forum
Prema

Vector Visualisation in SMS

Recommended Posts

Hi,

I'm having difficulty viewing vectors overlain on contour plots in solution files.

These are the steps I have been following:

  1. Run Bouss 2D or ST Wave (those are the two models i currently use);
  2. Load the corresponding solution file;
  3. Enable both Contours and Vectors in the display options menu
  4. In the Vectors tab, select display ‘on a grid’ and ‘Fixed length’;
  5. Click on 'Wave Height' in the Project Explorer toolbar to generate the resultant wave height contour plot;
  6. Click on ‘Wave Direction’ ;
  7. Select Data from Menu Bar and scroll to Data Set Toolbox;
  8. Select Scalar to Vector conversion, select Sig Wave height for Vx and Mean Wave Direction as Vy and choose the Magnitude and Direction option in the bottom right tab;
  9. Click on Compute to calculate and output the wave direction grid;and
  10. Select 'Wave Height' grid and ensure the ‘new data set’ is active.

These steps have previously generated a wave height contour plot with wave direction displayed as vectors, overlain on the wave height image.

On numerous occasions, I have found difficult to see the vectors as they seem to be displayed on a separate layer underneath the contours. I can see them more clearly if I reduce the transparency level of the contour dataset but this decreases the contour visibility.

Would you please advise.

Regards,

Prema.

Edited by Prema

Share this post


Link to post
Share on other sites

In a 3D display system like SMS, data can get hidden behind data with a larger z value.

The solution to this is to use the offset field in the vector options tab to raise the vector arrows. The amount the offset needs to be depends upon the steepness of your solution but 20 is generally enough for me.

I hope this helps.

Hi,

I'm having difficulty viewing vectors overlain on contour plots in solution files.

These are the steps I have been following:

  1. Run Bouss 2D or ST Wave (those are the two models i currently use);
  2. Load the corresponding solution file;
  3. Enable both Contours and Vectors in the display options menu
  4. In the Vectors tab, select display ‘on a grid’ and ‘Fixed length’;
  5. Click on 'Wave Height' in the Project Explorer toolbar to generate the resultant wave height contour plot;
  6. Click on ‘Wave Direction’ ;
  7. Select Data from Menu Bar and scroll to Data Set Toolbox;
  8. Select Scalar to Vector conversion, select Sig Wave height for Vx and Mean Wave Direction as Vy and choose the Magnitude and Direction option in the bottom right tab;
  9. Click on Compute to calculate and output the wave direction grid;and
  10. Select 'Wave Height' grid and ensure the ‘new data set’ is active.

These steps have previously generated a wave height contour plot with wave direction displayed as vectors, overlain on the wave height image.

On numerous occasions, I have found difficult to see the vectors as they seem to be displayed on a separate layer underneath the contours. I can see them more clearly if I reduce the transparency level of the contour dataset but this decreases the contour visibility.

Would you please advise.

Regards,

Prema.

Share this post


Link to post
Share on other sites

Hi Rusty,

I use the same method that you noted and in many cases it works, but I also faced some cases which even with 100 offset in the vector still the vector layer is underneath the contours.

Is there any other way to rectify this problem?

Kind regards,

Hamid

Share this post


Link to post
Share on other sites

Hi,

I don't know of another way.

There isn't a problem with making those more than 100 if that is necessary.

Hi Rusty,

I use the same method that you noted and in many cases it works, but I also faced some cases which even with 100 offset in the vector still the vector layer is underneath the contours.

Is there any other way to rectify this problem?

Kind regards,

Hamid

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...