Sign in to follow this  
Followers 0
M O K

STWAVE problems with 10.1

4 posts in this topic

Hi,

I was trying to run STWAVE with spectrum input + currents (currents from an adcirc run (fort.64) on the same grid I am importing to SMS for the STWAVE run) and when I try to create the 2D CGrid I get the error that I did not specify any data for the currents (see attached current.jpg) - but I did select the velocity file (I tried this for single time step and all time steps ). So, I decided that maybe there is something wrong with my files and moved on to the SMS-STWAVE tutorial provided (everything I will mention from this point on is based on the files provided with the tutorial). Using SMS 10.1 and following the tutorial I get the same error (it works in SMS 10.0) - I am using the grid and h5 file provided with the tutorial - (a bug?).

Anyway, I got around the problem by using SMS 10.0 and creating the 2d Cgrid in SMS 10.0 (spectrum + currents from the fort.64 file) and saving as a SMS file then I could open it in SMS 10.1.

At this point I have several other problems that I cannot get around. I will try to list them as clear as possible.

With SMS 10.0 & data files provided with tutorial:

-everything in the tutorial works - I see the difference in wave height with and without currents (only 1 time step as said in tutorial) in the results (very little difference at the entrance of the Shinnecock Inlet probably because the currents are weak)

-when I try to run with all time steps for currents - SMS 10.0 crashes - shows me the send report pop up window. (with my own data the run starts and immediately stops giving me the orrtl: severe (170): Program Exception - stack overflow error )

With SMS 10.1 & files saved in SMS 10.0 after creating the 2d Cgrid (since creating the 2d grid does not work with currents as I mentioned above)

-SMS 10.1 does not crash with currents loaded for each time step BUT the solution for wave height does not change for time steps. In model control: Current Interaction is set to currents and the file is selected (see attached model control.jpg). After doing that I checked the Boundary Conditions (see attached boundary.jpg) and I see that the Currents TS shows only the first time step. I tried with the first and last step to see if that made any difference on the results - still no change.

With SMS 10.1 & files saved in SMS 10.0 after creating the 2d Cgrid (since creating the 2d grid does not work with currents as I mentioned above)

-I tried to run STWAVE with only spectrum and with spectrum + currents (only 1 time step) and the results do not change.

After all the trials, I feel like there is something wrong with current interaction in SMS 10.1 starting at the point where I try to create the 2D Grid and even when I went around that problem the results (wave heights) did not seem to change

and

in SMS 10.0 all time steps can be loaded but I cannot run it to see if it works because it crashes with the tutorial files and it gives the stack overflow error with my own data)

I might have forgotten to mention some important points and I am willing to cooperate to solve the issues. Next step will be to add the surge output from adcirc (which I already tried in SMS 10.1 - spectrum + currents + surge (all time steps) and the results were the same for each time step)

sorry it has been a long one, I hope it will be addressed.

MO

Share this post


Link to post
Share on other sites

Thank you for your interests in the SMS software and for your detailed description of the problems that you encountered with the STWAVE module.

We reviewed the tutorial and were able to locate the first problem that you came across when you tried to create the 2D Cartesian Grid. The Currents interpolation bug has been recognized and is in the process of being fixed.

We have not yet evaluated the problems that were encountered with SMS 10.0.

The reason your results were not changing after running STWAVE is because your dataset only has a single time step. The time step window by defaults shows all the time steps for all datasets in SMS. Therefore you see the time steps from the mesh datasets even if you are looking at the STWAVE results. You can change this behavior to only show timesteps from the current module in preferences. Right clicking on a dataset and choosing options will show information about the dataset including time steps. You will see your dataset only has one.

If you want to setup STWAVE to use several or all time steps, you will have to turn on the “Use Time Steps” check box in the Model Control dialog. Then go to the Boundary Conditions dialog and notice that in the “Events” spreadsheet, each line will represent one time step. If you wish to view changes for each time step then you will have to enter data for each time step (spectra and current timestep to use). This will require that you have a transient current dataset in your Cartesian Grid. In this way, you can choose which time steps you want represented and include a unique time value in Currents TS.

We hope that these suggestions will solve your issues.

SMS Team

Share this post


Link to post
Share on other sites

Great! thanks for the reply. I will definitely try these.

Thank you for your interests in the SMS software and for your detailed description of the problems that you encountered with the STWAVE module.

We reviewed the tutorial and were able to locate the first problem that you came across when you tried to create the 2D Cartesian Grid. The Currents interpolation bug has been recognized and is in the process of being fixed.

We have not yet evaluated the problems that were encountered with SMS 10.0.

The reason your results were not changing after running STWAVE is because your dataset only has a single time step. The time step window by defaults shows all the time steps for all datasets in SMS. Therefore you see the time steps from the mesh datasets even if you are looking at the STWAVE results. You can change this behavior to only show timesteps from the current module in preferences. Right clicking on a dataset and choosing options will show information about the dataset including time steps. You will see your dataset only has one.

If you want to setup STWAVE to use several or all time steps, you will have to turn on the “Use Time Steps” check box in the Model Control dialog. Then go to the Boundary Conditions dialog and notice that in the “Events” spreadsheet, each line will represent one time step. If you wish to view changes for each time step then you will have to enter data for each time step (spectra and current timestep to use). This will require that you have a transient current dataset in your Cartesian Grid. In this way, you can choose which time steps you want represented and include a unique time value in Currents TS.

We hope that these suggestions will solve your issues.

SMS Team

Share this post


Link to post
Share on other sites

MO,

The interpolation issue has been resolved. Any versions of SMS created after 2009-10-30 will no longer have this issue.

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0