Jump to content
GMS, SMS, and WMS User Forum
US_AA

Linking 2D/2D

Recommended Posts

Hi,

I am using TUFLOW in SMS 10.1 and I would like to link a fine Grid in some areas to a coarser Grid. We already ordered the multiple domains license. When I try to link the two 2D domains according to the help file on http://www.xmswiki.com/xms/SMS:TUFLOW_Linking_2D_Domains as below

To setup multiple 2D domains in SMS:

1. Create multiple TUFLOW grids and associated grid components.

2. Define a 2D/2D Linkage coverage and attributes (see below).

3. Add all the 2D domains being used and the 2D/2D Links Coverage to the simulation.

the program always tells me, that "this component already has a grid linked to it!".

So what can I do to get this thing done?

I already posted my question in the TUFLOW forum and they gave me a Tutorial. Unfortunately the multiple domains tutorial is not yet documented and so it is not easy to understand, how to use this tool.

Kind regards

post-1233-125594125044_thumb.jpg

Edited by US_AA
  • Like 1

Share this post


Link to post
Share on other sites

O.k., I just found out how to use it. But after starting the simulation, a new problem occurs. While opening the files, the system is telling me that the simulation_name.tcf file does not exist. The thing is, that actually this file existits at the location the system is seeking. For more details, please have a look at the attached image.

Kind regards and thanks in advance!!!

post-1233-125594771754_thumb.jpg

Share this post


Link to post
Share on other sites

I'm not sure what is happening.

Could you get your files to technical support (support@aquaveo.com)? Tell them to get them to Rusty.

O.k., I just found out how to use it. But after starting the simulation, a new problem occurs. While opening the files, the system is telling me that the simulation_name.tcf file does not exist. The thing is, that actually this file existits at the location the system is seeking. For more details, please have a look at the attached image.

Kind regards and thanks in advance!!!

Share this post


Link to post
Share on other sites

I was able to see what was causing the immediate problem and have a couple pointers:

The problem was caused because SMS was writing a blank file for the boundary condition file to the tcf file. We will look to see if we can make this work better in SMS. SMS seems to get confused because there is no BC coverage in the 1m component (even though there is one in the 4m component). If you right click on the bc coverage used in the 4m component, there is an option to duplicate the coverage. In the duplicate coverage remove all the bc types that would be outside the grid in the 1m case (turn all the tidal bc etc to Not Used). Then add this coverage to the 1m component.

This should get you past problem #1.

The 2D/2D coverage stores which grid is used for each polygon. Double click on each of the polygons in the coverage and select the appropriate 2D domain (it looked like both were set to 4m).

Another item that obviously didn't make it into the documentation is that the spacing along the arcs bordering two 2D domains is important to passing the data between the two. The rule of thumb is to have them 1.5 times the largest cell size.

I did run into another issue with materials. It seemed like SMS was having a hard time with the font or something on my computer. It wasn't finding the correct material for the default material in the grid options dialog. Once I changed it to a different name it worked fine.

I hope this helps.

O.k., I just found out how to use it. But after starting the simulation, a new problem occurs. While opening the files, the system is telling me that the simulation_name.tcf file does not exist. The thing is, that actually this file existits at the location the system is seeking. For more details, please have a look at the attached image.

Kind regards and thanks in advance!!!

Share this post


Link to post
Share on other sites

Thanks, your pointers helped me to get over my .tcf file problem and the simualtion now starts without complaining. But (I really feel sorry for asking you another question) there is still one problem left. When I am using multiple domains, the simualtion always gets unstable. I already reduced the timestep to 0.1 s but my simulation is still not working proper.

Regards

Edited by US_AA

Share this post


Link to post
Share on other sites

What is the spacing of the vertices on the arcs of the boundaries of the domains?

Is it going unstable near one of the boundaries that join the domains?

Thanks, your pointers helped me to get over my .tcf file problem and the simualtion now starts without complaining. But (I really feel sorry for asking you another question) there is still one problem left. When I am using multiple domains, the simualtion always gets unstable. I already reduced the timestep to 0.1 s but my simulation is still not working proper.

Regards

Share this post


Link to post
Share on other sites

The spacing varies between some 400m in the outer boundary and circa 300m in the inner (2D/2D Linkage) border. I did not redistribute the vertices, they are spread like it reasulted from drawing them.

And yes, it is getting unstable near one of the boundaries that join the domains.

While having a look a the results (so far), it seems as if there would be another inlet in the finer Grid (see the attchment). The problem is, I did not define this inlet. I already had a related problem in the outer BC as you can see a the following link:

http://aquaveo.invisionzone.com/index.php?showtopic=757&st=0&p=2124&fromsearch=1entry2124

I was told to set up a negative flow as downstream BC; this worked faultlessly. But In the finer Grid, there is no seperate BC.

I hope you can help me to get rid of this unsolicited "inlet",

thanks and regards!

post-1233-125619830651_thumb.jpg

Share this post


Link to post
Share on other sites

I want you to redistribute the vertices on the 2D/2D linkage border.

From my earlier post "Another item that obviously didn't make it into the documentation is that the spacing along the arcs bordering two 2D domains is important to passing the data between the two. The rule of thumb is to have them 1.5 times the largest cell size."

Also, are the elevations in the fine grid low enough that the initial water level is responsible for the water in the domain?

The spacing varies between some 400m in the outer boundary and circa 300m in the inner (2D/2D Linkage) border. I did not redistribute the vertices, they are spread like it reasulted from drawing them.

And yes, it is getting unstable near one of the boundaries that join the domains.

While having a look a the results (so far), it seems as if there would be another inlet in the finer Grid (see the attchment). The problem is, I did not define this inlet. I already had a related problem in the outer BC as you can see a the following link:

http://aquaveo.invisionzone.com/index.php?showtopic=757&st=0&p=2124&fromsearch=1entry2124

I was told to set up a negative flow as downstream BC; this worked faultlessly. But In the finer Grid, there is no seperate BC.

I hope you can help me to get rid of this unsolicited "inlet",

thanks and regards!

Share this post


Link to post
Share on other sites

I want you to redistribute the vertices on the 2D/2D linkage border.

From my earlier post "Another item that obviously didn't make it into the documentation is that the spacing along the arcs bordering two 2D domains is important to passing the data between the two. The rule of thumb is to have them 1.5 times the largest cell size."

Also, are the elevations in the fine grid low enough that the initial water level is responsible for the water in the domain?

O.k., I did what you advised me. But after simulating some minutes the model is still getting unstable. Before using the multiple domains, the model was working well. Now it is also getting unstable in areas, where there is not as yet water.

Some unstabilities occur at the borders of my GM Coverage, which defines the buildings in my model; the unstabilities are mostly inside the finer (1m) Grid.

So what should we do???

Share this post


Link to post
Share on other sites

Hi,

I am not sure if you read my posting (a week ago). Because I have to provide some results I hereby want to ask you again.

Before using the multiple domains, the model was working well. Now it is also getting unstable in areas, where there is not as yet water.

Some unstabilities occur at the borders of my GM Coverage, which defines the buildings in my model; the unstabilities are mostly inside the finer (1m) Grid.

Do you have some hints to reduce unstabilities within my model?

Thanks

Edited by US_AA

Share this post


Link to post
Share on other sites

I'm not sure what would be happening.

Please contact technical support (support@aquaveo.com) and work with them to get your files uploaded to us. Tell them Rusty wants to take a look at them.

Hi,

I am not sure if you read my posting (a week ago). Because I have to provide some results I hereby want to ask you again.

Before using the multiple domains, the model was working well. Now it is also getting unstable in areas, where there is not as yet water.

Some unstabilities occur at the borders of my GM Coverage, which defines the buildings in my model; the unstabilities are mostly inside the finer (1m) Grid.

Do you have some hints to reduce unstabilities within my model?

Thanks

Share this post


Link to post
Share on other sites

Hi,

I have looked over your model and while it still goes unstable for me, I do have a couple suggestions. With the exception of #1, they aren't necessarily problems but things to think about and try.

1. If you open the "*_grd_check.mif" in SMS (from the check files directory), you will see that the elements from both domains are showing up in your refined portion of the model. If you right click on each of the grids, and choose options and set the default code to "Inactive cell -- not in mesh" you won't have these duplicate cells.

2. Your initial water level in your model should match the water surface elevation boundary condition at the start time of your model. If you want your grid to start all dry, you should make your bc curve match.

3. Your boundary conditions seem a little odd. Your water surface elevation is moving up and down a lot for a small arc on the right side of your grid but the flowrate is constant along a huge boundary on the other side. I'm not saying they are necessarily wrong but it seems like kind of a strange scenario.

4. I like to keep the connections between 2D domains as simple as possible. I would make your smaller domain straight across horizontally and take up the whole corner of your domain (extend it to the South to the edge of the domain). This will make a larger small grid but will make it so there is only two edges where the flow transitions between the domains.

Anyway, those are some things that I noticed and would try if I were working on the model.

I'm not sure what would be happening.

Please contact technical support (support@aquaveo.com) and work with them to get your files uploaded to us. Tell them Rusty wants to take a look at them.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...