Jump to content
GMS, SMS, and WMS User Forum
Chris Blount

10.1 beta bug?

Recommended Posts

I can't seem to get the nodestrings for ADCIRC to display right in the 10.1 beta. It seems like the different boundary conditions don't show up as the representative colors. I thought maybe it was stuck on the default color, saved as part of the project and I couldn't figure out how to change it back. So I tried just opening the grid I was working on in a new session on 10.1 and it still didn't work right. So I tried it in 10.0 and it works okay. Also, when I tried to renumber the grid I got an error saying something about part of the grid being disjoint (which was true) and it was highlighted in red (which it wasn't). So that's another display problem to check.

While I'm posting about this, I have two other general comments about nodestrings. 1.) I think the instructions that display on the bottom about going CW and CCW are reversed. 2.) The nodestring direction depends on whether it's an internal or external boundary so it would be helpful if there was a way you could incoporate a check or automatic correction of the direction when the boundary condition is assigned. I'm working with large grids with lots of islands (100+) in some instances and I've had problems with the nodestring problem before. And this is a rather tedious thing to check.

Chris

Edited by Chris Blount

Share this post


Link to post
Share on other sites

Chris,

Questions:

  1. Boundary conditions don't show up as the representative colors
  2. Disjoint areas not highlighted in red
  3. Instructions that display on the bottom about nodestrings going CW and CCW are reversed
  4. Nodestring direction depends on whether it's an internal or external boundary so it would be helpful if there was a check or automatic correction of the direction when the boundary condition is assigned

Responses:

  1. Have you tried this with the new update? I wasn't able to recreate the problem
  2. I was able to reproduce and have reported this as a bug
  3. I was able to reproduce and have reported this as a bug - the instructions are correct for external boundaries, but wrong for internal boundaries (islands)
  4. I will add this as a suggestion for improving SMS

Share this post


Link to post
Share on other sites

Chris,

Questions:

  1. Boundary conditions don't show up as the representative colors
  2. Disjoint areas not highlighted in red
  3. Instructions that display on the bottom about nodestrings going CW and CCW are reversed
  4. Nodestring direction depends on whether it's an internal or external boundary so it would be helpful if there was a check or automatic correction of the direction when the boundary condition is assigned

Responses:

  1. Have you tried this with the new update? I wasn't able to recreate the problem
  2. I was able to reproduce and have reported this as a bug
  3. I was able to reproduce and have reported this as a bug - the instructions are correct for external boundaries, but wrong for internal boundaries (islands)
  4. I will add this as a suggestion for improving SMS

John,

The latest update fixed the problem with the colors. Thanks for your work.

Chris

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×