Jump to content
GMS, SMS, and WMS User Forum
Sign in to follow this  
Lubomir B.

RMA2 error in GFGEN when nodes > 10000

Recommended Posts

I have setup with little more than 10000 nodes

and when I run SMS if firsts starts GFGEN and prepares geometry and end with error (or it seems so)

listing from GFGEN

====== TABS-MD GEOMETRY FILE GENERATION PROGRAM ======

====== GFGEN VERSION 4.56 1D AND 2D CAPABILITY ======

====== LAST MODIFICATION DATE: 04-18-2005 ======

>>> Plotting de-activated <<<

>>> Original Author: Dr. Ian P. King of RMA <<<

>>> Modified and Maintained by USACE ERDC:CHL <<<

This executable is dimensioned for

Maximum node number = 225000

Maximum element number = 75000

.

.

.

--> Binary geometry file has been written

Num of unused nodes exceeds MAXUUN= 10000 STOP in info_geo.

and I cannot continue ..... when I execute Run RMA2 from SMS second time

it runs without problems since binary geometry exists ....... and RMA2 calculates results no problem

Is 10000 nodes too high for RMS2, the above mentioned ERROR message of GFGEN is

not documeted anywhere.

If it is an error in GFGEN plese forward this to autor of the code

thanks

Share this post


Link to post
Share on other sites
Num of unused nodes exceeds MAXUUN= 10000 STOP in info_geo.

This has happend to me every once in a while. In those cases i had nodes, that did not belong to any elements. You could try if you have the same problem. In SMS 9.0 mesh module there is a menu command 'nodes/select disjoint' which should select the unused nodes. After selecting them you can delete them by pressing 'del'. Alternatively, try and copy r2memsize.dat (should be in your models directory) to your working directory where the model is and change the parameter MXUU to some higher value. This should get you rid of the error message.

heimo

Edited by heimo

Share this post


Link to post
Share on other sites

I have no unused nodes .... all are members of the net

that is why I consider this an error

This has happend to me every once in a while. In those cases i had nodes, that did not belong to any elements. You could try if you have the same problem. In SMS 9.0 mesh module there is a menu command 'nodes/select disjoint' which should select the unused nodes. After selecting them you can delete them by pressing 'del'. Alternatively, try and copy r2memsize.dat (should be in your models directory) to your working directory where the model is and change the parameter MXUU to some higher value. This should get you rid of the error message.

heimo

Share this post


Link to post
Share on other sites

On the Aquaveo downloads page, in the "Utilities" section, you can download different versions of GFGEN:

  • GFGEN 10k Nodes - 190 KB
  • GFGEN 20k Nodes - 193 KB
  • GFGEN 55k Nodes - 199 KB
  • GFGEN 5k NODES - 143 KB

Share this post


Link to post
Share on other sites

Hi

I am facing a problem when trying to run my RMA2 model.

I just would like to run my model succesfully but seems like I was not even able to run the RMA2 itself.

I've attached my output file.

Could somebody explain to me why I failed running my GFGEN?output_5.txt

Share this post


Link to post
Share on other sites

I believe the problem comes from the amount of nodes and elements that I had in the model which is more than 10,000 elements and more than 30,000 nodes.

Is there anything I could do to use bigger grid or to eliminate the excessive elements and nodes without removing my data?

I hope I could hear from anyone soon.

Thank you!

Cheers

Vera Kurniawan

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...