Jump to content
GMS, SMS, and WMS User Forum
Jose Maria

Import from Web

Recommended Posts

Hi, Colleagues:

Please, could you give me a hand? I am trying to get an image to fit my tidal propagation. After doing what the tutorial tells, I get an error message: "(0,0): System argument exception: Invalid parameter, etc".

Is there any way to fix the problem?

Thank you very much.

Jose

Share this post


Link to post
Share on other sites

Jose,

A couple of questions:

  1. Are you using the latest version of SMS? - See "Help | About" should be SMS 10.0.11 / Build Date: Feb 10, 2009
  2. Is it possible that your firewall is blocking SMS from contacting the image server?
  3. Do the steps work when you do the tutorial?

Share this post


Link to post
Share on other sites

Hi, John:

  1. No, I'm using version 10.0.10. It's the one I found in the recent DVD I received.
  2. I disconnected the firewall to prevent this issue.
  3. No the tutorial does not run.

In the meanwhile, I'll try to download the last version of SMS and I'll try again.

Thanks for your help.

Best regards,

Jose

Share this post


Link to post
Share on other sites

Jose,

Let us know if downloading the latest version fixes the problem. We release updates to SMS almost every month, as shown here. The releases address any issues we have found through our internal testing and issues that have been reported to us via the forum or technical support.

Thanks,

John

Share this post


Link to post
Share on other sites

No, I could not fix the problem.

By the way: you have a small mistake on the year of the last release: Intermediate release SMS 10.0.11 - February 10, 2008.

Thanks to you.

Jose

Share this post


Link to post
Share on other sites

Jose,

A couple of things to try:

  1. Do you have microsoft .NET 2.0 installed? To run Terraserver in SMS 10.0, you need at least .NET version 2.0. If you do not, you can use the full installation rather than the executable update and check the box to install .NET 2.0. To check if you have .NET version 2.0, from a command prompt type regedit and then browse to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP. You should see the entries for .NET.
  2. If you browse to C:\Program Files\SMS 10.0 you will see VirtualEarth.html and WinformsEarthV2.exe. The date modified should read 10/10/2008 if you have the latest version. If you click on WinformsEarthV2.exe do you get the same error you mentioned before?

- John

Share this post


Link to post
Share on other sites

Hi again, John.

Yes, I found Net Framework in my register.

Referring to the files, they are dated 10/10/2008. WinformsEarthV2.exe opens its window; when I click OK, get no error, but it do nothing, simply it close the window.

Jose

Share this post


Link to post
Share on other sites

Jose,

WinformsEarthV2.exe appears to be working properly. Did you try to reinstall SMS using the full installation and checking the box to install the .NET framework?

- John

Share this post


Link to post
Share on other sites

Jose,

This is a tricky one! Can you browse to: C:\Program Files\SMS 10.0 and run sys_info.exe? Please post the results here.

- John

Share this post


Link to post
Share on other sites

Sure, here you are:

Processor:

Intel® Core2 Quad CPU Q9400 @ 2.66GHz

Memory:

4.00 GB

Operating System:

Microsoft® Windows Vista™ Business

Service Pack 1

Video Card:

Make: Intel Corporation

Model: Intel® 4 Series Express Chipset Family

Name: Intel® Q45/Q43 Express Chipset

Memory: 1.51 GB

Display:

Driver Version: 7.15.10.1608

Driver Date: 12/2/2008

Mode: 1280 x 1024 x 32 bit color

OpenGL:

Version: 2.0.0

Extensions:

GL_EXT_blend_minmax

GL_EXT_blend_subtract

GL_EXT_blend_color

GL_EXT_abgr

GL_EXT_texture3D

GL_EXT_clip_volume_hint

GL_EXT_compiled_vertex_array

GL_SGIS_texture_edge_clamp

GL_SGIS_generate_mipmap

GL_EXT_draw_range_elements

GL_SGIS_texture_lod

GL_EXT_rescale_normal

GL_EXT_packed_pixels

GL_EXT_separate_specular_color

GL_ARB_multitexture

GL_EXT_texture_env_combine

GL_EXT_bgra

GL_EXT_blend_func_separate

GL_EXT_secondary_color

GL_EXT_fog_coord

GL_EXT_texture_env_add

GL_ARB_texture_cube_map

GL_ARB_transpose_matrix

GL_ARB_texture_env_add

GL_IBM_texture_mirrored_repeat

GL_EXT_multi_draw_arrays

GL_NV_blend_square

GL_ARB_texture_compression

GL_3DFX_texture_compression_FXT1

GL_EXT_texture_filter_anisotropic

GL_ARB_texture_border_clamp

GL_ARB_point_parameters

GL_ARB_texture_env_combine

GL_ARB_texture_env_dot3

GL_ARB_texture_env_crossbar

GL_EXT_texture_compression_s3tc

GL_ARB_shadow

GL_ARB_window_pos

GL_EXT_shadow_funcs

GL_EXT_stencil_wrap

GL_ARB_vertex_program

GL_EXT_texture_rectangle

GL_ARB_fragment_program

GL_EXT_stencil_two_side

GL_ATI_separate_stencil

GL_ARB_vertex_buffer_object

GL_EXT_texture_lod_bias

GL_ARB_occlusion_query

GL_ARB_fragment_shader

GL_ARB_shader_objects

GL_ARB_shading_language_100

GL_ARB_texture_non_power_of_two

GL_ARB_vertex_shader

GL_NV_texgen_reflection

GL_ARB_point_sprite

GL_EXT_blend_equation_separate

GL_ARB_depth_texture

GL_ARB_texture_rectangle

GL_ARB_draw_buffers

GL_ARB_pixel_buffer_object

GL_WIN_swap_hint

GL_EXT_framebuffer_object

Share this post


Link to post
Share on other sites

Hi Jose,

I'm sorry about the problems that you are having.

We have been made aware recently that SMS doesn't get the temporary directory correctly sometimes for computers outside of the US. I'm not sure how computers know they are not in the US.

Could you try something for me? Go to Edit | Preferences and override the default temporary directory to one that you create for this purpose. See if this fixes the problem you are experiencing.

Share this post


Link to post
Share on other sites

Don't worry at all. Getting problems with a new model (I mean "new" for the user) is expected. I have been working a lot of years with Mike system and I decided changing to SMS: I was perfectly aware that I was having some problems. Anyway, you can be proud of your service on line.

Well, coming back to our business, I keep having problems. But, in my humble opinion, they could come either from connection with TerraServer or from API of Windows Vista:

(0,0):System.Argument.Exception: The parameter is not valid.

at System.Drawing.Bitmap..ctor(Int32 widht, Int32 height, PixelFormat format)

at terraserver.Form1.GetImage()

at terraserver.Form1.TerraServer()

Regards,

Jose

Share this post


Link to post
Share on other sites

Hi Jose,

One last question, where is the data that you are trying to download. Even though we use the Virtual Earth to locate the location for the download, the data comes from Terraserver which unfortunately only contains US data. If you are trying to download data outside the US, try downloading US data just as a test.

Share this post


Link to post
Share on other sites

Hi, Rusty:

You have found the problem: I was trying to download a picture of the Gulf of Cadiz. I tried the U.S. and it works. I thought TerraServer had the whole world.

Thank you very much for the answer, and thanks also to John for his help. Sorry for having bothered you, John.

Best regards,

Jose

Share this post


Link to post
Share on other sites

Sorry for the confusion caused by the interface. I hope you are able to find another source for your data. If you know of good European sources for imagery or elevation data, let us know. We will post information about them on our Wiki.

Hi, Rusty:

You have found the problem: I was trying to download a picture of the Gulf of Cadiz. I tried the U.S. and it works. I thought TerraServer had the whole world.

Thank you very much for the answer, and thanks also to John for his help. Sorry for having bothered you, John.

Best regards,

Jose

Share this post


Link to post
Share on other sites

No problem.

Respecting info at Europe, I currently use Google Earth, or MS Visual Earth. Respecting Spain, there are fairly good images at the GIS of Ministry of Environment: http://sig.mapa.es/geoportal/.

The problem is that world file must be "selfbuilt", since they does not allow to download georreferenced files :angry: .

I'll update this info as soon as I get more data or they are updated.

Thanks for all.

Jose.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...