Jump to content
GMS, SMS, and WMS User Forum
Britt McMillan

x-sec to tin surf

Recommended Posts

Using build 6.5.4

I have reproduced the following response using the tutorial files:

1. Open holes.txt

2. automatically create blank x-section

3. Open top_elev.tin

4. Snap to TIN works correctly

BUT if I:

1. Open holes.txt

2. Manually create the same x-section as shown on sect 6.3 of the Strat Modeling tutorial

3. Open top_elev.tin

4. Snap to Tin gives the following error message: "Top Arc on cross section(s): .... can not be snapped to TIN because it does not have any vertices."

I'm hoping I'm missing a simple step.

thanks

Edited by Britt McMillan

Share this post


Link to post
Share on other sites

Without looking at the tutorials, I can tell you that your top arc needs vertices to snap to the TIN. I typically open up the cross-section editor, select the top arc, right click the mouse, redistribute the vertices (I pick a number that will give me a reasonable spread), then snap to TIN. You could also manually add vertices before you snap to the TIN.

Share this post


Link to post
Share on other sites
Without looking at the tutorials, I can tell you that your top arc needs vertices to snap to the TIN. I typically open up the cross-section editor, select the top arc, right click the mouse, redistribute the vertices (I pick a number that will give me a reasonable spread), then snap to TIN. You could also manually add vertices before you snap to the TIN.

Thanks for the response - I discovered this feature while working with a much larger data set. I did try the "snp to tin" on both the larger data set early on and the manually constructed x-section in the tutorial - it did not change the resutls (same error message). I only tried the tutorial to see if I could reproduce the issue with a "standard" data set - which it did.

As a side note - it is strange that the "automatic x-section" tool works fine - without requiring "snap to tin" but the manually created x-section does not (I even tried the automatic x-section before importing the tin...).

Also - I tried creating a tin using the original boreholes (imported as a scatter point converted to tin) - so the location of the vertices should have matched exactly with the bore hole top elevations...worked OK with the automatic x-section but NOT with the manual x-section...

Thanks

Edited by Britt McMillan

Share this post


Link to post
Share on other sites

Okay - now I better understand your post. Interesting. I'm using the cross-section editor a lot right now and haven't run into that problem, but have noticed an interesting "bug" (which I haven't reported since I'm not totally sure it is a bug yet) - If working on a couple of cross-sections at once in the editor, I sometimes can't draw a line in the active cross-section, but if I flip it around (mirror view) so that it is on the right side, I can draw the line.

The only reason I bring it up is because there could be minor flaws still with the cross-section editor, but I think most can be worked through. Perhaps doing a mirror view in your case could make it work??? Just brainstorming.

Share this post


Link to post
Share on other sites
Okay - now I better understand your post. Interesting. I'm using the cross-section editor a lot right now and haven't run into that problem, but have noticed an interesting "bug" (which I haven't reported since I'm not totally sure it is a bug yet) - If working on a couple of cross-sections at once in the editor, I sometimes can't draw a line in the active cross-section, but if I flip it around (mirror view) so that it is on the right side, I can draw the line.

The only reason I bring it up is because there could be minor flaws still with the cross-section editor, but I think most can be worked through. Perhaps doing a mirror view in your case could make it work??? Just brainstorming.

Thanks - I'll try the mirror view --- Q: did you try to reproduce my error using the tutorial file (as a standard?) and it worked OK...and are you using the current build - tyring to figure out if it's me or the program.

Share this post


Link to post
Share on other sites

Some additional information:

I went back to my original data set - I had not manually connected ALL the boreholes for x-sections.

So, taking the manually created x-section - I used the "auto create blank sections" to fill in the portions I didn't connect - which it did ok.

I then went to "snap x-section to tin" and the sections that were auto created were correctly "snapped" but the ones that were manually created were not...same error message for the ones manually created.

Manually creating with a "mirror view" didn't work either.

Stumped.

Share this post


Link to post
Share on other sites

I just took a few minutes more to look at this and will have to think about it more later. There are multiple ways to do things in GMS. I don't typically use the menu to snap the x-section to the tin, because I want to look at each one individually as it does the snapping, so, as I said, I pull up each cross section, add vertices on the top line and then snap to the tin. I then create my polygons in the cross-section. With your method, if the user creates the polygons and then snaps to the tin, it can sometimes produce weird results in your cross-section. That's not what you are asking, but it is the reason I do them individually.

I pulled up the holes.txt file, made one cross-section. Went in and had it automatically generate polygons. Pulled up the tin file, tried snapping outside of the editor and wasn't shocked to see the error you mentioned, because I hadn't added any vertices to the top line of the cross-section. I went in and did that, came out and tried again. It snapped fine that time.....but again, that isn't necessarily a great way to go, because a dip in the stratigraphy could cut into a lower polygon, thereby making the cross-section invalid. For all I know, that could be causing the error.

Share this post


Link to post
Share on other sites
Some additional information:

I went back to my original data set - I had not manually connected ALL the boreholes for x-sections.

So, taking the manually created x-section - I used the "auto create blank sections" to fill in the portions I didn't connect - which it did ok.

I then went to "snap x-section to tin" and the sections that were auto created were correctly "snapped" but the ones that were manually created were not...same error message for the ones manually created.

Manually creating with a "mirror view" didn't work either.

Stumped.

For the cross sections that you manually created you will need to make sure that the top arc has vertices. That means you will have to go into the cross section editor and select the top arc, right click and select the redistribute vertices command.

The cross sections that are created automatically by the command Auto-create blank cross sections automatically have the vertices redistributed by a factor that is specified in the Preferences dialog under the Boreholes section: Default spacing/length ratio. For this reason it is only the manually created cross sections that do not have the vertices on the top arcs.

Share this post


Link to post
Share on other sites
I just took a few minutes more to look at this and will have to think about it more later. There are multiple ways to do things in GMS. I don't typically use the menu to snap the x-section to the tin, because I want to look at each one individually as it does the snapping, so, as I said, I pull up each cross section, add vertices on the top line and then snap to the tin. I then create my polygons in the cross-section. With your method, if the user creates the polygons and then snaps to the tin, it can sometimes produce weird results in your cross-section. That's not what you are asking, but it is the reason I do them individually.

I pulled up the holes.txt file, made one cross-section. Went in and had it automatically generate polygons. Pulled up the tin file, tried snapping outside of the editor and wasn't shocked to see the error you mentioned, because I hadn't added any vertices to the top line of the cross-section. I went in and did that, came out and tried again. It snapped fine that time.....but again, that isn't necessarily a great way to go, because a dip in the stratigraphy could cut into a lower polygon, thereby making the cross-section invalid. For all I know, that could be causing the error.

Thanks for looking at this - in my original data set (not the tutorial) I compensated for the "dip in stratigrpahy" by adding the top elevation of the boreholes to the scatter point file that I used to create the tin. That way I had vertices in the Tin that exactly matched the top elevation for each borehole - and therefore no error in interpolation. I have the same error message with or without these additional vertices added in.

I haven't tried bringing up individual x-sections to snap to the tin...not even sure how but will try (it doesn't seem to be covered in the "official" tutorial documentation...). I was hoping the "official" way would work as it is suppose to...

Britt

Share this post


Link to post
Share on other sites
For the cross sections that you manually created you will need to make sure that the top arc has vertices. That means you will have to go into the cross section editor and select the top arc, right click and select the redistribute vertices command.

The cross sections that are created automatically by the command Auto-create blank cross sections automatically have the vertices redistributed by a factor that is specified in the Preferences dialog under the Boreholes section: Default spacing/length ratio. For this reason it is only the manually created cross sections that do not have the vertices on the top arcs.

I tried it and it worked! Thanks...must of missed it in the documentation...

Thanks everyone.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...