Jump to content
GMS, SMS, and WMS User Forum
speedy

Problem with Null-space Monte Carlo

Recommended Posts

Hi everybody

I have a model which I calibrated using PEST and SVD-Assist. The calibration was very good. When I try to run stochastic model with null space Monte Carlo then PEST runs only for one iteration and stops! I followed the exact steps in the tutorial and nothing is different. I am not sure why I got this problem. I appreciate your help.

 

Attached is a capture of the stochastic run window

 

Thanks

Capture.JPG

Edited by speedy

Share this post


Link to post
Share on other sites

Hi again

 

I figured out the reason behind this problem, which is the interpolation of pilot points data. I noted Null-space Monte Carlo works only with kriging! but I faced a problem with kriging. I have pilot points and selected kriging but when I try to run the calibration I have error messages shown below

Capture1.JPG

Capture2.JPG

Share this post


Link to post
Share on other sites

Thanks for no responses

 

I figured out the reason for these error messages. However, I found many problems in kriging in GMS, especially with calibration. I calibrated my model initially using inverse-distance method without any issue. But I had to use kriging to be able to use NSM and here all the problems appear. I defined the theoretical variogram based on experimental data but the error is huge. The other thing I was unable to click on the data truncation in the kriging menu, which is strange as this option is available when I interpolate the scatter data from scatter points menu. Moreover, PEST stops despite the error is huge when using kriging.

All in all, kriging with PEST in GMS is a big headache.

Anyone has any experience with this issue?

Share this post


Link to post
Share on other sites

Well, it seems my questions are so difficult to answer. Anyway, I have noticed many problems in kriging within GMS when using pilot points.

1) when building a variogram with data (model variogram using experimental one) these information are not saved anywhere. Every time I need to calibrate/re-calibrate I need to build the variogram again

2) when there is more than one parameter to be calibrated, the cut off values of kriging search takes always the range of the first parameter.

3) There is no way to see fitting error of experimental and model variogram to get the best fit.

4) As variogram information are not saved, after calibration you need to re-build the variogram for each paramter, which may result in a higher error than the calibration resu

 

Edited by speedy

Share this post


Link to post
Share on other sites

Hi speedy,

I have also struggled with krigging setting not saved properly. But this was solved in GMS 10.3.4. I have recently succesfuly solved inverse problem with Aquaveo MODFLOW model using PEST. There was pp kriging set up for several parameters. Although it worked ok for me , I would still prefer GMS to use native PEST tools for pp interpolation and PEST structure files for storing interpolation setting as it would allow us to use native USGS modflow for calibration with pilot points very easily.

Anyway, thank you for sharing your experience on the forum. It is always very helpful.

Best Michal

Edited by Michal

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×