Jump to content
GMS, SMS, and WMS User Forum
lebronkahn

HEC HMS extremely insensitive to changes in input.

Recommended Posts

lebronkahn    0

Hi, 

First I want to thank you for your time in advance. Any advice on this will be appreciated as I have been stuck on this problem for weeks now.

Here is the situation: I created this basin model with 101 sub-basins and 100 reaches. Pic attached: "Basin Model" (there is something wrong with the upload, I changed it to URL)

I am using one plane approach. No collector and subcollector channel information.

For the sub-basins, I use "SCS Curve Number" as Loss Method and "Kinematic Wave" as Transform Method; for the reaches, I use "Muskingum" Routing Method. As show in the attached: SubBasin and Reach.

In Meteorology Model: Precipitation is Specified Hyetograph

I followed every step of the example in the HEC guide, and the model runs and can generate results. However, I found out that, no matter how much I changed the parameters, the corresponding changes in the results were minimal. For instance, the default value I used for Length and Slope for subbasin main channels are 100ft and 0.01. After I acquired the real value through ArcGIS (much longer length and much smaller slope) and put them into the model, the results were almost the same(1855.5 CFS to 1855 CFS). I also tried change the Route Upstream for some sub-basins i.e. from No to Yes. Still minimal change.

Two things noteworthy and suspicious

  1. :every time I run the model, although the process can still go through, there will be warnings: Error in computing kinematic wave for subbasin SA 064;
         Estimation procedure for time step size failed to converge. 
    And this will persist for a lot of SAs (sub-basins). Couldn't find anything Google associated with this warning message. Any idea?
  2. When I print out the results, the header will show: Method: Snyder Transform. I know for a fact that I didn't use anything called Snyder. Where does this come from.

Please lemme know if I need to provide more details in order for this problem to be solved.

 

Thanks

 

Share this post


Link to post
Share on other sites

I am certainly not an expert on the Kinematic wave method implemented in HMS.  I wonder if you increase the number of subreaches on your kinematic wave channels and/or on the overland flow plane.  The default is five, but maybe increasing this value will make it so you don't get the first warning you're getting related to the time step.  Increasing your channel length by an order of magnitude and decreasing your slope by an order of magnitude should change your results, but maybe not by as much as you think.  I tried changing these numbers on a basin and increasing channel length/decreasing slope by a factor of 3 or 4 for each value resulted in only a 2% change in the peak flow.  The resulting hydrograph was slightly attenuated when I decreased the slope, and this was expected.  The amount of change in your peak flow (if nothing else has changed) seems low if you're referring to the results from changing a single basin in your model.

I have no idea why your method would show the Snyder method when you print the results.  How are you printing the results?  Are you using the HMS reporting tools in the Tools | Reports menu?  I usually look at the results in the "Results" tab in the HMS interface and I don't see a place where it prints the transform method in this area.

HEC does not provide direct support for their models, but you could try reporting your problem as a bug report to HEC and see if they respond to your problem or help with your modeling issues.  Their bug report page is located here: http://www.hec.usace.army.mil/software/hec-hms/bug_report.aspx

Hope this helps.  Let us know what you figure out so others will know how to solve similar problems,

Chris

Share this post


Link to post
Share on other sites
lebronkahn    0

Thank you so much for your reply. 

>> I am certainly not an expert on the Kinematic wave method implemented in HMS.

Me neither. First time doing this and apparently need more knowledge and digging up in the User Guide. But I have gone through it several times and still couldn't find out where I could have done wrong.

>> increase the number of subreaches on your kinematic wave channels and/or on the overland flow plane. 

I changed the Subreaches # of Reaches from 5 to 50. The warning messages persist and the results didn't change too much. Couldn't seem to find Subreaches on flow plane tho. There is routing step option with default value as 5. I changed it to 50 as well and ran it again (with both value set as 50). Same deal. Couldn't believe it.

>> Increasing your channel length by an order of magnitude and decreasing your slope by an order of magnitude

As I posted in original post, I changed these two factors pretty dramatically without inducing too much change in the corresponding results. Plus, the lengths and slopes are acquired from the ArcHydro, not sure if I shall change them.

>> show the Snyder method when you print the results.  

Sorry. I have to stand corrected on this one. It was not show on the result printout. Instead, it's the parameters printout. Parameters> Transform> Kinematic Wave. And it shows like this. Very confounded by it. 

>> Are you using the HMS reporting tools in the Tools | Reports menu?

Somehow I couldn't do it. It asks for style sheet, which I have no knowledge of. Seems like I need to select a file. Please help if you know how to proceed. I use the same approach as you do. 

I will definitely consider sending the HEC an email for some advice.

Share this post


Link to post
Share on other sites

I'm not sure why it's saying the Snyder method.  My version of HMS actually did not show the same screen as yours.  I wonder what version of HMS you're using.  I'm using version 4.1.  Send an email to or call Aquaveo Tech support if you want somebody here to look at your model and possibly help you.

As far as the style sheets and the reports menu, it's complicated to use.  A simple search on google for "Reports menu HMS style sheets" turns up some good results.  The best ones I've found are from HEC here and another one here.  You could just modify the style sheets included on these sites as needed.  Figuring out what names to use in the style sheets and the format is the hard part.  I don't have a good source for that.

Hope this helps, let me know if you're able to figure out anything with the kinematic wave routing.  You could always use the Snyder or Clark transform or just the SCS transform if nothing else works and if that option is available to you.

Chris

Share this post


Link to post
Share on other sites
lebronkahn    0

Hi Chris. 

I am using the version 4.2 

>>> Send an email to or call Aquaveo Tech support 

I sure will but before I do: do they help with HMS? 

Thanks for the style sheet, I will definitely read into them. 

BTW, what is Snyder transform exactly? Is it just the Snyder Unit Hydrograph for the Transform Method.

I will hang in there and keep cracking this thing lol. Appreciate your time and effort.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×