Jump to content
GMS, SMS, and WMS User Forum
Mark Prater

ADCIRC spatial attributes

Recommended Posts

Hi all,

I'm trying to load a spatial attribute file (fort.13) into SMS (v10.0.3), but SMS does not offer a "file type" for fort.13, athough one for fort.21 (friction) is included. The xmswiki described how to implement the attributes after they've been read in, but how do I read in the fort.13 file?

Thanks -- Mark

Share this post


Link to post
Share on other sites

Hi,

I might be wrong, but it is always worth a try, doesn't SMS load in the fort.13 file when it loads in the fort.15 file? I think in the past when I have used the spatial attributes function it has done this, although I may be wrong. If you just have a fort.13 file and no fort.15 file then just create a new fort.15 file with a new spatial attribute linked to it and then just change the resultant fort.13 file to the one you want and re-read the fort.15 file back in and it "may", hopefully will, read in the fort.13 file as well.

Ian

PS If it doesn't work it shouldn't have wasted too much time trying :)

Edited by walkington

Share this post


Link to post
Share on other sites

I am sorry to clutter your thread but I was unsure where else to post it.

I am currently working with ADCIRC v46.32 and need to have it read in fort.13. I have created a test fort.13 file and it reads the following:

QA_Grid

63

1

"quadratic_friction_coefficient_at_sea_floor"

ft^2/s

1

2.5E-3 1

"quadratic_friction_coefficient_at_sea_floor"

9

24 1.0

25 1.0

26 1.0

31 1.0

32 1.0

33 1.0

38 1.0

39 1.0

40 1.0

Upon running ADCIRC I receive the following errors:

ERROR: The Model Parameter File (unit 15)

contains invalid name: quadratic_friction_coefficient_at_sea_floor

ERROR: The Nodal Attributes File (unit 13)

contains invalid name: quadratic_friction_coefficient_at_sea_floor

****** FORTRAN RUN-TIME SYSTEM ******

Error 1083: unexpected character in integer value

Location: the READ statement at line 525 of "nodalattr.F"

Unit: 13

File: ./fort.13

Input: quadratic_friction_coefficient

1. I do not understand why it says its an invalid name.

2. line 525 wants to read in the NumNodesNotDefault, which is present (value of 9)

Any help would be much appreciated. Feel free to reply here or email me at etang858@gmail.com or eetang@ucsd.edu

Thanks so much,

Erik

Share this post


Link to post
Share on other sites

Erik,

After looking at the ADCIRC documentation nothing jumps out at me. Have you tried posting to the ADCIRC listserv? ADCIRC has a very active community and they have been very good at responding to questions in my experience.

http://www.adcirc.org/ There is an ADCIRC listserv that may be useful to keep up-to-date about the latest releases of ADCIRC and to post any questions about ADCIRC. It is adcirc@listserv.unc.edu. If you would like to join please email Crystal Fulcher.

- John

Share this post


Link to post
Share on other sites

From: Jason Fleming [mailto:XXXX@email.unc.edu]

Sent: Thursday, February 26, 2009 12:34 PM

To: coastal circulation model

Subject: Re: Re:[adcirc] Fort.13 reading problem

This issue has been resolved ... it was caused by the presence of preceding spaces in the attribute name ... this was a compiler dependent issue in old versions of ADCIRC (v46). This is not an issue in the latest version of ADCIRC.

Cheers

Jason

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...