Jump to content
GMS, SMS, and WMS User Forum

paving density mode loses resolution


Kai Li

Recommended Posts

Issue: When I trying to make a big mesh with paving density mode, some of the regions does not meshed with enough resolution. As you can see the colored background is the contour of scatter value. There is an obvious area where the mesh lose resolution.

So how can I avoid this? Is it caused by some kind of insufficient iteration or something else? Is there a simple option to correct this issue? Thanks!

post-12823-0-17121800-1371126590_thumb.p

Link to post
Share on other sites

There are two ways to increase resolution when using paving.

The first applies to regular paving (no scalar size function). To use this add a feature point or arc in the area you want the increased resolution and specify the desired resolution by assigning the refine attribute to the feature point or redistribute the feature arc.

The second applies to scalar paving. In this method you specify a size function in the form of a scattered data set. When using this method, you can just create a new scatter vertex in the area where resolution is being lost and specify the size in that area to be smaller.

Link to post
Share on other sites

There are two ways to increase resolution when using paving.

The first applies to regular paving (no scalar size function). To use this add a feature point or arc in the area you want the increased resolution and specify the desired resolution by assigning the refine attribute to the feature point or redistribute the feature arc.

The second applies to scalar paving. In this method you specify a size function in the form of a scattered data set. When using this method, you can just create a new scatter vertex in the area where resolution is being lost and specify the size in that area to be smaller.

Sorry for misunderstanding, I'm currently using scalar paving density mode, but the mesh result is not the same as I expected.

I mean in the picture I attached, the red area should have higher resolution than blue area, but it's not that.

By the way, I've tried sms 11.0.12 and 11.1.5, and I got the same result.

Link to post
Share on other sites
  • 5 weeks later...

Sorry for the delay in getting you a response.

The contours you are displaying are from the scatter set based on the legend. The range of sizes is 10-3 to 10-5 and your coordinates show geographic.

I recently found a tolerance issue bug in the mesh generator that has caused some issues when paving in geographic coordinates. I am adjusting those tolerances and I think it should be fixed (at least significantly improved) in the next update of SMS.

I personally try to avoid using fractional degrees as the size because the values don't mean anything to me intuitively. You could reproject to a UTM zone and pave there, but you would need to scale the size values (data values for the scatter set) up to make them meters rather than degrees.

The other thing you could do is get the build next month (or off of the nightly builds) to see if it addresses your problem. If not, then you could report it to SMS tech support to get the specific issue addressed.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...