Jump to content
GMS, SMS, and WMS User Forum
ht512

Problem Running Modflow [Always stops at 25 of timestep 1 of period 1]

Recommended Posts

Hi,

I am working on a project examining the effect of land-use and climate change on groundwater flow for a specific area in Thailand. The model covers approximately 550km2 and has 10 layers, covering 5 geological layers (I have experimented with less numbers of layers but does not seem to get the interaction between the geological structure right). So far, I have tried running the model with two basic boundary conditions; recharge and lake, to see if ModFlow would work. I was successful in running the model once but tinkered with the re-wetting option and have been unsuccessful in running the model since. Having relentless changed the various settings before running ModFlow again and again, the model seems to stop at [25 of timestep 1 of period 1; MODFLOW-2000 terminated without converging; MODFLOW terminated with error!].

The problem persisted when the whole model was set up again, stopping at the same point and with a different error, [The LAK Pakage is used in flow simulation; the Link-MT3DMS file must be saved with EXTENDED header.; MODFLOW terminated with error], having already chosen the extended header format for output control.

Could anyone kindly provide some guidance to why this may be?

Your time in much appreciated.

Tan

Share this post


Link to post
Share on other sites

If you are not doing transport then I would just turn off the Link-MT3DMS file in the output.

However, my guess is that even without Link-MT3DMS turned on your model will still stop. Let me know what it says after you turn that option off.

Share this post


Link to post
Share on other sites

Hi Alan,

Thank you very much for your prompt reply. Yes that is indeed the case. Once switched off, ModFlow still stops at the same place. Please kindly advise.

Thank you.

Share this post


Link to post
Share on other sites

I'm thinking that you have your maximum number of iterations set at 25 for your solver package, so it will always stop there if it doesn't converge. While you could increase the number of iterations, it also sounds to me like your rewetting is causing you problems....which is VERY common. If you can work around the use of rewetting, you will be better off.

Share this post


Link to post
Share on other sites

I agree with Sean. If you can create the model without rewetting you will be better off. You can try using MODFLOW-NWT which is better at handling the wet/dry condition.

Share this post


Link to post
Share on other sites

Hi Sean and Alan,

Thank you very much for your kind replies. I have changed the maximum number of iterations in the solver package and everything seems to run fine using the MODFLOW2000. I have tried switching to MODFLOW-NWT and so far it has worked fine as well.

Both models seems to work for transient but not steady state simulation. Rewetting does not allow the models to converge under the circumstances I have tried. Could you kindly advise to why this may be.

After obtaining the results from the successful transient runs, I would like to view the simulated heads on different day of the run. I have tried clicking on the dates on the time scale to the bottom left of the user interface but the head does not seem to move. Is there a display option that I need to activate for this to work?

Thank you again for all your help.

Hongthai

Share this post


Link to post
Share on other sites

If you have not been able to get a steady state model to work then I would be very suspicious of the results from the transient model.

There can be many, many reasons why a model does not work. A good place to start is the model checker to see if there are any obvious problems (MODFLOW | Check Simulation). Also, when a model does not converge it is useful to look in the *.out file and see what information is printed there. Sometimes you can see the cells where the greatest head change is occurring on each iteration. You can then go look at those areas in your model to see if the model inputs have are what you think they should be.

Share this post


Link to post
Share on other sites

Hi Alan,

Thank you very much for you reply. I will address all the things you have mentioned over the weekend and will let you know how the model gets on.

Hongthai

Share this post


Link to post
Share on other sites

Actually, because you are still using rewetting, I'm not shocked by your statement that steady state didn't converge while transient did. Often times, the "jump" that the steady state calculation makes in an iteration is too large to allow a cell to converge, while the transient time steps allow the convergence to happen. If you take the transient simulation far enough along, you can sometimes use the last time step's results as your starting heads for your steady state simulation and find success. Because the result doesn't have to change significantly, you can get convergence.

Share this post


Link to post
Share on other sites

Hi Alan and Sean,

Thanks to your guidance, I have been successful in running transient simulations (10 stress periods, 10 days time steps) for parts of my study area using MODFLOW-NWT. The current problem that I am having now is running the same simulation for my entire study area which is about 544km2. There are only three boundary conditions that I am using; 1) Wells, 2) Recharge and 3) Specified Head (CHD). I am using the last to specify the coastline in the model.

When checking for model errors for a small sample area, two things come up; 1) Starting head lower than bottom elevation in cell [...] and 2) The changing head boundary is below the bottom elevation of cell [...]. I have been able to run the simulation regardless of these errors and the results seem appropriate. Same errors appear when trying to simulate the whole study area but MODFLOW does not converge. The only parameter I have tried changing so far is the MAXITEROUT in the Newton Solver (to 2000) but this has not changed anything. I have the *.out file for the simulation should you want to see it. Please let me know what is the best way to send this you (the text file is 14.4MB).

Your advice is greatly appreciated.

Hongthai

Share this post


Link to post
Share on other sites

My advice - fix the errors with the CHD. I'm actually shocked that you were able to run the simulation with those errors. It would also be best to fix the starting head errors as well, since having too many cells drying out will often cause issues with convergence.

Share this post


Link to post
Share on other sites

Hi,

This is how I proceeded to fixing the two errors mentioned before;

1) Starting head lower than bottom elevation in cell [...]: CELLS WERE IN K=1 AND WERE DEACTIVATED

2) The changing head boundary is below the bottom elevation of cell [...]: CELLS WERE IN K=1 TO K=4. THEIR SPECIFIC HEADS WERE DELETED FROM 'SOURCES/SINKS' BUT CELLS REMAINED ACTIVE

After cell deactivation in layer 1 the following error appear: 3) Warning: Time var. spec. head in an inactive cell i=xx, j=xx, k=1. These cells were identified and activated again through changing their IBOUND value to 1.

Tried running the model but did not work until 'Do not stop on non-convergence (NOSTOP)' was selected int he PEST-ASP Options. The results seems to be in line what what I have been expecting but would be grateful if you could kindly explain the implications of the NOSTOP option so I am aware of any errors that may come with the results.

Thank you again.

Hongthai

Share this post


Link to post
Share on other sites

With regard to reactivating those cells, don't you then get the error again which would have your changing head boundary below the bottom cell elevation? Seems like you still have some issues to deal with there. Either get your boundary condition to be above the bottom of the cell, or only have it in the layer below where you are getting an error.

Sorry, but I don't have experience with the NOSTOP option.

Sean

Share this post


Link to post
Share on other sites

Hi Sean,

Thank you for your reply. Those reactivated cells with 'Warning: Time var. spec. head in an inactive cell i=xx, j=xx, k=1' had 'Starting head lower than bottom elevation in cell i=xx, j=xx, k=1' instead. From what I understand these are just dry cells and they do not affect the ability of the model to run.

It would be great if you could provide more information about the NOSTOP option.

Thank you again.

Hongthai

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...