Sign in to follow this  
Followers 0
verakurniawan

Error when trying to run GFGEN

13 posts in this topic

Hi

I am facing a problem when trying to run my RMA2 model.

I just would like to run my model succesfully but seems like I was not even able to run the RMA2 itself.

I've attached my output file.

Could somebody explain to me why I failed running my GFGEN?output_5.txt

Thanks!

Regards

Vera Kurniawan

Share this post


Link to post
Share on other sites

I believe the problem comes from the amount of nodes and elements that I had in the model which is more than 10,000 elements and more than 30,000 nodes.

Is there anything I could do to use bigger grid or to eliminate the excessive elements and nodes without removing my data?

I hope I could hear from anyone soon.

Thank you!

Cheers

Vera Kurniawan

Share this post


Link to post
Share on other sites

Hi again

I tried to remove significant numbers of data and see whether the GFGEN program ran. It looked like the GFGEN program ran but then I had another problem.

I am attaching the output file once again output_test2.txt, I really appreciate any suggestion to solve my problem.

Need a BIG help in here! Thanks!

Cheers

Vera Kurniawan

Share this post


Link to post
Share on other sites

Vera,

I believe you can overcome this by changing your 'r2memsize.dat' - file. First, copy it to the directory where your model (.bc, .bin etc) are. Then change the parameter under MCCN to a larger number with notepad or other text editor. (This might also help in your other topic of maximum number of unused nodes exceeded (parameter MXUU)).

Hope this helps,

Heimo

Share this post


Link to post
Share on other sites

Hi Heimo

First of all thanks for your respond and help.

Where could i find 'r2memsize.dat' file? I could not find it in my SMS folder.

Cheers

Vera Kurniawan

Share this post


Link to post
Share on other sites

Heimo

By the way I am using SMS 8.1 and RMA2 v 4.35 for running my model. Is there any possibilty not to have r2memsize.dat file because I am using older version of the model? Do i have any other option to modify the max number of continuity check lines without this r2memsize.dat file?

Hope to hear from you soon!

Thank you

Vera Kurniawan

Share this post


Link to post
Share on other sites

Vera,

I'm using a newer version of RMA2 (v4.54) with SMS9.0. It seems that the older version you are using does not support dynamic allocation of memory as it was just added to v4.54. Here is the version history from

http://chl.erdc.usace.army.mil/chl.aspx?p=s&a=ARTICLES;394

Version 4.54 (May 2002)

RMA2 static memory was converted to dynamic memory allocation. Minor bug fixes and enhancements.

The files r2memsize.dat and r4memsize.dat are situated at the 'models'-directory (where rma2v45.exe etc are located).of SMS installations since SMS9.0

I am not sure, if your licence agreement allows this, but you could download a newer version of SMS full installation and get the new rma2 (and rma4 if necessary) from that package. Then, you need to point your SMS to these executables (in SMS9 it is done in Edit/Preferences/File Locations)

Regards,

Heimo

Share this post


Link to post
Share on other sites

Hi again Vera,

If you can't upgrade your rma2 executable, a not so elegant way could be to split your check line (providing you are using them as boundary conditions). Here are two pictures, where the left side of the grid is divided to three bounday lines. Note that there needs to be a disabled element (show as black triangle in the image) between two boundary lines (i.e. they cannot be connected). In this example, the boundary lines have incoming discharges of 500, 100 and 500 m3/s and the right side is surface elevation boundary.

post-25-0-91437900-1331794558_thumb.jpg

post-25-0-00613600-1331794573_thumb.jpg

Edited by heimo

Share this post


Link to post
Share on other sites

Heimo

Thank you so much for your respond and help. It helps me a lot. I really appreciate it.

I was suspecting the same reason too why I could not find the r2memsize.dat file that everyone is talking about.

I am trying to download the newer version of sms from SMS download page, but i doubt that I could upgrade my SMS and RMA2 version.

So I can say that I could not modify the maximum nodes to be used in my model as well. Am I correct?

Because I do have lots of data, and when I created the mesh it gave me more than 20,000 elements which then I saw from my output file, my max elements allowed is only 10,000. Should I use smaller data then? Or is there anyway to use all my data and makes the elements size bigger (to reduce the number of the elements)?

Oh by the way, thanks for the great idea of dividing the boundary condition to few boundary conditions =). I could run the model with small data, but then other problem appears " STOP depth convergence exceeds 25.0". =(

I hope to hearing from you soon again. Thanks, Heimo.

Vera Kurniawan

Share this post


Link to post
Share on other sites

I am trying to download the newer version of sms from SMS download page, but i doubt that I could upgrade my SMS and RMA2 version.

I believe you can install the new SMS (preferably to different pc than what you are using), then copy the rma2/rma4 executables and the dat-files to your pc. After that you can uninstall the new SMS (as you will not have the password for that). Now you have the new models.

On the other hand - I have an installation package of the models (without SMS) that was downloaded from aquaveo some years ago (in 2008). There is, among others, v454 of rma2. I can mail it to you if you give your e-mail address. The file size is 8.4 Mb. Or I could zip just rma2/4, gfgenv45 and dat files (size 950 kB) and mail you that.

So I can say that I could not modify the maximum nodes to be used in my model as well. Am I correct?

Because I do have lots of data, and when I created the mesh it gave me more than 20,000 elements which then I saw from my output file, my max elements allowed is only 10,000. Should I use smaller data then? Or is there anyway to use all my data and makes the elements size bigger (to reduce the number of the elements)?

Yes, I think you can't modify the max node number in your version of the programs.

Of data size,

Is there need for high resolution at boundaries? You could make the elements there larger by redistributing the vertices on the boundary (-ies). Just select the bounday arc and select 'Feature Objects/Redistribute vertices' and give a reasonably large value (mesh size) for the vertex spacing. That also reduces the number of points in the arc, so that (with luck) you would not have to split the arc as given in my previous posting. This redistribution can be done of course also for shoreline arcs. Please, save your original map data however, first. Redistributing a complex shoreline with too large vertex spacing can lead to an unwanted shoreline apperance (details smaller than the spacing will be removed).

The other way to decrease the number of elements is to use so called refine points. In the doc below is a short example. In short, add (in map coverage) some points inside your mesh to areas of lesser importance, assign the points as refine points (well, we should in this case name them the opposite) and regenerate the mesh with an outcome of larger element sizes near the points). You can give each point a different size value or same value for all points.

Refine.doc

Regards,

Heimo

Edited by heimo

Share this post


Link to post
Share on other sites

Hi Heimo

I am so glad that you keep helping me on solving my problem.

By the way, I would love to have the installation package that you have for newer version of RMA2, you could send me at my email here

I hope you could send that big file to me safely =)

I will try your suggestion soon and i'll let you know whether it works. I hope so!

Cheers

Vera Kurniawan

Edited by verakurniawan

Share this post


Link to post
Share on other sites

Hi!

I tried to send the 8Mb and the 950 kB from my work pc, but that didn't succeed. I also tried to send the smaller package (a zip file) from my person e-mail account but failed. I got the following error message:

(at the end f it, there's "Our system detected an illegal attachment on your message." so it seems attachements are not allowed in the mail?)

"

Edited by heimo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0