Jump to content
GMS, SMS, and WMS User Forum
AMAL

problem map femwater conceptual model to 3Dmesh

Recommended Posts

Hi, I am a new user of GMS 8.1

Kindly can you help me to solve this problem

I will explan how i create femwater coceptual model,

1- I create my femwater coceptual model with one coverage (wells, BC)

2- I create 2D mesh and I renumbere it.

3- I create solids from Borehole by using horisons to solids.

4- I selecte solid/solids to layerd mesh and i got a good 3D mesh

The problem

5- I started new simulation then I do map/ femwater the program give mi this warning

No 3D mesh nodes lie within the screend interval of well id: 1235.

when I select Ok the warning continued to apper many many time with other id wells,

then mapping cmplet and warning wells have not maped and i can't see them in 3D mesh.

I have more than 3000 wells and 8 layers 356 Km2

For all wells I defie these data X, Y, Z, TOB&POT scr, Pum Rate m3/d.

I import a text file as well data and I haven’t any problem.

In 3D mesh I see all wells inside the 3D mash as suspended columns, the max well depth is -120 m and the 3D mesh domain is start from 120 m and end in -200 m USL.

So why cannot be mapped to the mesh? wher is the error?

Share this post


Link to post
Share on other sites

I have not used wells in Femwater, but it sounds like Femwater is trying to identify which mesh node(s) correspond to each well screen. How long are the well screens? What is the vertical mesh spacing? I think you need to have at least one mesh point within the well screen. I think Femwater considers wells to be flux boundary conditions that are applied at specific nodes. Are the well x,y positions located at mesh nodes?

Share this post


Link to post
Share on other sites

Thank you for your replay,

How long are the well screens?

screen wells are long between 100 m and 30m. ex (z terrain= 30, top scr =0, bott scr = -100)

What is the vertical mesh spacing?

vertical mesh spesing is between 120 m and -200m

Are the well x,y positions located at mesh nodes?

yes ,I verify that all wells at mash nodes in 2D mesh and in the 3D mesh

but i note that some z wells in 3D mesh are above or below mesh nodes, I try to copy the X, Y, Z of the node to the well but the problem is still in mapping coverage to femwater

you seid "I think you need to have at least one mesh point within the well screen"

how i can verify it?

arround the 3D mesh i see vertical nodes which correspondiing to layer ellevations and inside I see suspended well screens.

in femwater there is a limited number of wells for a limited area ? for ex femwater con not maped more than 100 wells in 1 m ?

I have 3000 wells in 356 Km2.

Share this post


Link to post
Share on other sites

Hi Amal

If your well screen lengths are >= 30m, then if you have a vertical mesh spacing of <=30m you will ensure that there will be at least one mesh node in each well screen.

If you want bigger mesh spacing > 30m, maybe the easiest thing is to artificially increase the well screen length upwards (are they in confined layers?).

PS: I just checked the gwpara.inc file, which sets the size of the arrays in Femwater, and it only allows MXWNPH = 60 well nodes ("max well nodal points for head"). So you will need to get the source code from Aquaveo and recompile it with MXWNPH = 3000.

Edited by woodward

Share this post


Link to post
Share on other sites

Thank you Mr woodward,

I modify well screens and they mapped to femwater.

I have other problem. when i do run femwater after finish running i don't see the file solution in the project explorer.

in check simulation I have tis warning:

MATERIALS:

Warning: Kxx values between elements 3 and 273 differ by more than 3 orders of magnitude.

Warning: Kxx values between elements 17 and 299 differ by more than 3 orders of magnitude.

Warning: Kxx values between elements 29 and 324 differ by more than 3 orders of magnitude.

Warning: Kxx values between elements 47 and 365 differ by more than 3 orders of magnitude.

Warning: Kxx values between elements 61 and 391 differ by more than 3 orders of magnitude.

Share this post


Link to post
Share on other sites

Hi Amal

GMS puts the Femwater input and output files in a separate directory FEMWATER_projectname

The Femwater manual (pager 18) recommends you don't have hydraulic conductivity change by more than 3 orders of magnitude between adjacent elements, because it can cause poor convergence or poor accuracy.

Share this post


Link to post
Share on other sites

THANK YOU Mr Woodward,

I have a sandy layer with a k= 30 m/d above a clay layer with a k=0.01 m/d, flowing one to ather for 8 layer.

i modify K of the clay layer to 10 m/d and i haven't any warning, is this correct? I give a different parameter value form the realistic parameter to make the parameter acceptable for the program??? we have to simulate the realistic situation since it is possible.

nay way , I run the FEMWATER and after 20sce it finish give mi this massage in the run window:

you must increase the parameter MAXELK to 183003.

after closing the window I see the femwater solution in the project explorer.

Share this post


Link to post
Share on other sites

Does it actually give you a solution? If you look in the project explorer, are the output files there? e.g. *.phd *.vel *.mcn *.flx *.con (depending on what you asked for)

The MAXELK warning would suggest it is not actually running. MAXELK is the maximum number of elements allowed in the model. It is set in the gwpara.inc file. To increase it, you need to recompile Femwater.

Share this post


Link to post
Share on other sites

Mr.WOODWARD,

thank you for your replay.

I tried to recompile the femwater3.exe using the modify gwpara.inc file in FORTRAN compiler but the new executable file not works.when I used the not modified gwpara file to compile it I get a correct file and it works. I used the femwater example to verify if the new femwater.exe works or not.

Kindly I have some questions:

when we use windows 32bit system have femwater parameters limits ?

when I make any change femwater parameters have some relation between them to be considered ?

There is any problem or restriction with my windows system 32bit and AMD Athlon 64bit dual core CPU?

I attach my model parameter, are it executable parameter for femwater?

THANK you in advance.

my model parameter.txt

Share this post


Link to post
Share on other sites

Did your new Femwater give you an error message?

Yes some of the parameter in gwpara.inc are related. I think this is probably your problem.

Some of the them are listed in the header comments in the femwater.f file.

* DESCRIPTION OF PARAMETERS

*

* The list and definition of the control parameters required

* for the model are given below:

*

* MAXNPK = maximum number of nodes in the 3-D mesh

* MAXELK = maximum number of element in the 3-D mesh

* MXBESK = maximum number of boundary-element surfaces

* MXBNPK = maximum number of nodal points at the boundary

* MXJBDK = maximum number of element for node connectivity

* MXKBDK = maximum number of element for element connectivity

C

* Material and Soil Properries

*

* MXMATK = maximum number of soil types

* MXSPMK = maximum number of data points to describe soil

* characteristic curve in unsaturated zone

* MXMPMK = maximum number of material properties per material

* (hydraulic conductivity)

* MXRMPK = maximum number for coefficients of the viscosity and

* density functions

*

* HEAD Boundary Conditions

*

*

* For flow simulation:

*

* MXDNPH = maximum number of head nodal points

* MXDPRH = maximum number of head profiles

* MXDDPH = maximum number of data points on each profile

*

* For transport simulation:

*

* MXDNPC = maximum number of concentration nodal points

* MXDPRC = maximum number of concentration profiles

* MXDDPC = maximum number of data points on each profile

*

* NXG = maximum number of grids for element tracking in

* x-direction

* NYG = maximum number of grids for element tracking in

* y-direction

* NZG = maximum number of grids for element tracking in

* z-direction

*

* FLUX Boundary Conditions

*

*

* 1. Cauchy flux boundary condition:

*

* For flow simulations:

*

* MXCNPH = maximum number of flux nodal points

* MXCESH = maximum number of flux element surfaces

* MXCPRH = maximum number of flux rate profiles

* MXCDPH = maximum number of data points on each flux rate

* profile

*

* For transport simulations:

*

* MXCNPC = maximum number of nodal points for

* concentration

* MXCESC = maximum number of element surfaces for

* concentration

* MXCPRC = maximum number of concentration profiles

* MXCDPC = maximum number of data points on each

* concentration profile

*

* 2 Neumann flux boundary condition:

*

* For flow simulations:

*

* MXNNPH = maximum number of flux nodal points

* MXNESH = maximum number of flux element

* surfaces

* MXNPRH = maximum number of fluxrate profiles

* MXNDPH = maximum number of data points on

* each flux rate profile

*

* For transport simulations:

*

* MXNNPC = maximum number of nodal points for

* concentration

* MXNESC = maximum number of element surfaces

* for flux rate

* MXNPRC = maximum number of concentration

* profiles

* MXNDPC = maximum number of data points on

* each flux rate profile

*

* Rainfall-Seepage Boundary Conditions

*

*

* For flow simulations:

*

* MXVNPH = maximum number of ground nodal points

* MXVESH = maximum number of ground element surfaces

* MXVPRH = maximum number of rainfall-seepage profile

* MXVDPH = maximum number of data points on each rainfall-

* seepage profile

*

*

* For transport simulations:

*

* MXVNPC = maximum number of ground nodal points

* MXVESC = maximum number of ground element surfaces

* MXVPRC = maximum number of rainfall-seepage profile

* MXVDPC = maximum number of data points on each rainfall-

* seepage profile

*

* Source/Sink Boundary Conditions

*

*

* For flow simulations:

*

* MXWNPH = maximum number of well nodal points

* MXWPRH = maximum number of well source/sink profiles

* MXWDPH = maximum number of data points on each well

* source/sink profile

*

* For transport simulations:

*

* MXWNPC = maximum number of well nodal points for

* concentration

* MXWPRC = maximum number of well source/sink profiles

* for concentration

* MXWDPC = maximum number of data points on each well

* source/sink profile

Share this post


Link to post
Share on other sites

Mr.WOODWARD,

Thank you very mach Mr Woodward

I try to modify the gwpara.inc by adding 0 for every parameter in order to keep the relation between them but the fortran can not create the .exe file and give mi a fatal error.

I noted that in the example of the FEMWATER tutorial the vertical spacing is not long just as the layer spacing but there is some nodes which divide the segment to an equal small segmentes .

but in my model the vertical spacing is by two nodes ,first in the top layer and the second in the bottom layer which linked by one segmente without any divided nodes as in the example.

is there any error in my model?

in my model the vertices destripution is 300 and the aquifer spasing is between 30 and 100 m

THANK you in advance.

Share this post


Link to post
Share on other sites

Are you saying your mesh only has a single layer? Then Femwater is not the right model to use. Femwater model unsaturated-saturated flows, and unsaturated flows required relatively fine vertical mesh spacing. It is quite different to MODFLOW. I would say Femwater is not a good model for modelling saturated flows only.

I'm not sure why you are having trouble compiling the exe. One thing is that you need to allocate enough memory in the compilation - I had to increase the stack size in the compiler options at one stage to get this to work.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...