Jump to content
GMS, SMS, and WMS User Forum
karunakar

Meshing large domains

Recommended Posts

hi all.,

i've been thinking of this for the last couple of months.

Some time ago, i was referring to a paper by Westerlink, parrish and others regarding the mesh generation using ltea + cd for WNAT model.

and in SMS the LTEA asks for the projection to be in UTM coordinates (ref Meters not in degrees).

sometimes it is very difficult to convert a bigger domain into said coordinates, where it may span into different utm zones.

even if we manage it out with Transverse mercator some how, after meshing conversion back will distort elements too much at borders, particularly towards corners of the domain selected.

any suggestions on this topic are most welcome.

for Rusty:

hi jones, i would like to ask you regarding how much time it would take to mesh a domain similar to that of WNAT.

most of the times the SMS package goes "Not Responding" and no feed back from "paving interior(X)" in the bottom left of the window.

and the toolbars get distorted after mesh generation, sometimes which if adjusted make the software unstable.

is there any auto save sort of option available with SMS.,

excuse me if i'm ignorant of any options and rules.,

thank you all.

Share this post


Link to post
Share on other sites

Hi Karunakar,

You bring up a good question with LTEA using UTM. I don't have a good answer and am asking around to see what I can come up with.

On the other items...

I am not sure how long it would take to mesh something similar to the WNAT. If you are talking about the 2.2 M node mesh, it may take a significant amount of time. I would recommend using the 64-bit version of SMS for something this large and obtain as much RAM as possible (I run with 12 GB and others here have over 20).

SMS goes into unresponsive mode when it is busy doing calculations or other things. It doesn't necessarily mean that it is stuck permanently but that it is busy. I would let it run for a couple hours on domains less the 1M nodes and overnight for domains larger than this. If it doesn't become responsive by this time, please contact support@aquaveo.com and send them your files so we can take a look at what is happening.

Sorry, SMS doesn't currently have an autosave feature.

Thanks for questions. Hopefully, we can come up with a good answer on your main question.

hi all.,

i've been thinking of this for the last couple of months.

Some time ago, i was referring to a paper by Westerlink, parrish and others regarding the mesh generation using ltea + cd for WNAT model.

and in SMS the LTEA asks for the projection to be in UTM coordinates (ref Meters not in degrees).

sometimes it is very difficult to convert a bigger domain into said coordinates, where it may span into different utm zones.

even if we manage it out with Transverse mercator some how, after meshing conversion back will distort elements too much at borders, particularly towards corners of the domain selected.

any suggestions on this topic are most welcome.

for Rusty:

hi jones, i would like to ask you regarding how much time it would take to mesh a domain similar to that of WNAT.

most of the times the SMS package goes "Not Responding" and no feed back from "paving interior(X)" in the bottom left of the window.

and the toolbars get distorted after mesh generation, sometimes which if adjusted make the software unstable.

is there any auto save sort of option available with SMS.,

excuse me if i'm ignorant of any options and rules.,

thank you all.

Share this post


Link to post
Share on other sites

hi rusty.,

sry for long break.

any suggestions??

Hi Karunakar,

You bring up a good question with LTEA using UTM. I don't have a good answer and am asking around to see what I can come up with.

On the other items...

I am not sure how long it would take to mesh something similar to the WNAT. If you are talking about the 2.2 M node mesh, it may take a significant amount of time. I would recommend using the 64-bit version of SMS for something this large and obtain as much RAM as possible (I run with 12 GB and others here have over 20).

SMS goes into unresponsive mode when it is busy doing calculations or other things. It doesn't necessarily mean that it is stuck permanently but that it is busy. I would let it run for a couple hours on domains less the 1M nodes and overnight for domains larger than this. If it doesn't become responsive by this time, please contact support@aquaveo.com and send them your files so we can take a look at what is happening.

Sorry, SMS doesn't currently have an autosave feature.

Thanks for questions. Hopefully, we can come up with a good answer on your main question.

Share this post


Link to post
Share on other sites

I did work with Scott Hagen at UCF using SMS and the LTEA toolbox to generate a variety of meshes for the WNAT. Mesh generation times vary based on the number of nodes in the mesh, but all of our times were less than 20 minutes. We generated meshes with 30,000 nodes up to 200,000 nodes.

The reason that SMS asks for a coverage in UTM is because element sizes make much more sense in meters than they do in fractional degrees. The Global Mapper reprojection tools allow you to convert from geographic coordinates for a large domain (like the WNAT) to a central UTM zone fairly easily. There is some spatial distortion. If that is a problem, you could generate the mesh in pieces by creating subdomains. However, I wouldn't recommend this unless you are running out of memory. It is a useful method for refining sections of existing meshes.

The SMS LTEA toolbox converts the UTM domain that you provide it into geographic space before running ADCIRC and performing the LTEA analysis. However, that analysis does assume an underlying delta x value of 1 km, so the process requires that SMS convert back to Cartesian space.

I have had some problems with the LTEA toolbox trying to run the entire process from beginning to end in a single step. If this becomes an issue, simply run the process in steps. The toolbox allows this with minimal effort.

I recently met with Michael Parrish and we discussed adding the LTEA+CD option to the toolbox, but it is not available now. If you have specific problems with the LTEA toolbox, please let me know. I'd like to get them resolved.

Share this post


Link to post
Share on other sites

Thanks for the suggestion Mr.Zundel.,

PS: Sorry for the delay.,

i was offshore for the past few months.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...