Jump to content
GMS, SMS, and WMS User Forum
Prema

TUFLOW

Recommended Posts

Hi all,

I have recently started using TUFLOW and am having a few difficulties with a Map Data feature. I currently have water level (WL) data at two ends of a horizontal boundary condition (BC) line (please see attached image) and need to interpolate WL the along the BC line. To do so, i've created two CN nodes, at the two ends of the BC line and have converted the BC to a HX line, so that it reads the values from each CN node and interpolates along the line. However, i cannot snap the CN points to the BC line as they are in different coverages. They sometimes display in the BC coverage but are not linked.

Has anyone faced this problem before?

Any help would be much appreciated.

Thanks,

Prema.

Share this post


Link to post
Share on other sites

Prema,

SMS does not snap nodes in one coverages to arcs in another coverage. I am not very well versed in TUFLOW but as far as I understand it, I am not sure if you are able to interpolate water surface elevations from one node to another node along an arc boundary condition. The WSE changes with time and I am not sure if there is an option to make it change with position as well. Would you be able to attach your image again, it did not seem to load correctly.

Also, it may be helpful if you send your files to support@aquaveo.com. It often helps us diagnose a problem if we have your model. To send us your files you need to first zip the files together. If the zipped file is less than 20MB you can just email the zipped files to us. If the zipped files are over 20Mb you will need to upload the files to our ftp site. To do this,

1. Create a new folder with a unique name on your computer and copy all of your project files into it. (please zip up the folder)

2. Open windows explorer (My Computer).

3. Enter "ftp://pubftp.aquaveo.com" in the address bar.

4. (If the "Log On As" dialog box appears) check the box labeled "Log on anonymously" and click "Log On".

5. Copy the folder with your project files in it into the "incoming" folder.

6. Send an e-mail to support@aquaveo.com telling us the name of the folder you uploaded and exact steps taken to produce the problem.

*Please help us stay organized by putting all of your files in a single folder before you upload them. After you upload them, you will not be able to edit them.

Share this post


Link to post
Share on other sites

To add to what Erik has said, you can snap to feature objects in inactive coverages. Be sure that the display of inactive coverages is turned on. The as you create arcs in a new coverage, you'll notice a red cross appears when the arc will be snapped to a feature object in an inactive coverage. If you wouldn't mind, please do send your files to support@aquaveo.com so we can take a look and get and better idea of what you're trying to accomplish.

Share this post


Link to post
Share on other sites

Hi Tom and Eric,

Thank you very much for your comments. I had also emailed Rusty Jones about this issue and he had given me the following advice

-----Original Message-----

> From: Rusty Jones [mailto:rjones@aquaveo.com]

> Sent: Tuesday, 16 November 2010 9:28 AM

> To: Prema Bhautoo

> Cc: Technical Support

> Subject: Re: Snapping CN nodes to BC layer

>

> Hi,

>

> Due to differences in how we store and work with data, SMS puts CN

> lines and HX lines in separate coverages.

>

> For a CN line to be snapped to an HX line it has to be in the same

> physical location, you can have SMS snap points from different

> coverages together. They won't move together from then on and you will

> need to resnap them if you move one or the other.

>

> To snap:

> 1. Go to Edit | Preferences and make sure that snapping is on.

> 2. Go to Display Options and make sure that inactive coverages are

> being displayed.

> 3. Create arcs or points or drag points, when dragging points you

> should see a red plus sign at the point you are snapping to when you

> get close. When clicking they may just appear to jump slightly.

>

> There is one more little trick. The BC coverage needs to know which

> coverage to look into for its connection lines. You can right click on

> the BC coverage and choose properties to select this coverage. If you

> try to run a simulation where a BC coverage has HX lines and is not

> associated with a 1D/2D connection coverage, SMS will ask for the

> association so it generally gets filled in this way.

>

>> Cheers,

> Rusty

I have since tried it and it seems to work well.

Thank you very much for your help, it was much appreciated.

Prema.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...