Jump to content
GMS, SMS, and WMS User Forum

Simon W

Members
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Simon W

  • Rank
    New Member
  1. This relates to my previous post below. I've now narrowed down the problem more and feel confident reporting it as a bug. Steps to reproduce in SMS 13.0.8: Make sure a scatter set that is appropriate to use for a size function is present. In the Map module, create an arc that isn't a straight line, positioned such that some extrapolation, as well as interpolation, would be required to get estimate a value from the scatter set for some regions of the line. Select the arc in the Map module, right-click, choose Redistribute Vertices. Under "Arc redistribution", specify a size function and in Options, choose the scatter set in question. Choose linear interpolation, and open the next Options dialog (which is titled "Interpolate - Linear"). Leave "Truncate values" turned off. Under "Extrapolation", select "Constant" and enter a positive number in the "Value" text box. Remember this value. Switch the extrapolation method to Inverse Distance Weighted. Press OK through all the dialogs, so that the redistribution operation is performed. Inspect the parts of the arc that required extrapolation, and note that inverse distance weighted extrapolation has not been done as requested - instead, the spacing between vertices is exactly the number of metres that you entered in the "Value" box. Hopefully others can reproduce, and it isn't just something that happens with my dataset.... If I can usefully provide any further info, just ask.
  2. Hi all, I'm trying to use a size function to specify my mesh density, and in SMS v13.0.8 that means that I first need to redistribute the vertices on my arcs, using the same size function. When I do this, it mostly works nicely, except that certain parts of the arcs get very tightly-spaced vertices (it turns out that they are placed at the minimum distance that I set the size function to truncate at). They're on parts of the arcs that "stick out", though they don't go far beyond the scatter data. One such place is my model's open boundary. I've attached a couple of screenshots. In both cases the scatter data that you can see is the size data - included to illustrate that I'm not trying to extrapolate way beyond it. I've tried various different interpolation methods, and all give a similar result. Any ideas? Is this a bug, or am I doing something wrong? Thanks
  3. [duplicate post removed]
×
×
  • Create New...